# CVE-2025-47271: OZI-Project/ozi-publish Code Injection vulnerability

> A malicious actor can inject arbitrary code via branch names in the OZI-Project publish GitHub Action, leading to code execution.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2025
- **Updated:** 12 May 2025
- **Also known as:** GHSA-2487-9f55-2vg9

## What is CVE-2025-47271?

CVE-2025-47271 is a medium-severity code injection vulnerability in OZI-Project publish, published on 12 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The OZI action is a GitHub Action that publishes releases to PyPI and mirror releases, signature bundles, and provenance in a tagged release. In versions 1.13.2 through 1.13.5, potentially untrusted data flows into PR creation logic. A malicious actor could construct a branch name that injects arbitrary code. This is patched in 1.13.6. As a workaround, one may downgrade to a version prior to 1.13.2.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code), CWE-94 (Improper Control of Generation of Code), CWE-1116 (Inaccurate Source Code Comments)

## Which versions are affected by CVE-2025-47271?

1 open source package ship an affected version, including OZI-Project/publish.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `OZI-Project/publish` | GitHub Actions | From 1.13.2 | 1.13.6 |

## How do I fix CVE-2025-47271?

Upgrade OZI-Project/publish to 1.13.6 or later.

## Is CVE-2025-47271 being exploited?

There is no known exploitation of CVE-2025-47271 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47271 and fix it if it is affected.

What it is: CVE-2025-47271 is a medium-severity code injection vulnerability in OZI-Project publish, published on 12 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47271 in the wild and no public exploit code.

Affected packages and fixed versions:
- OZI-Project/publish (GitHub Actions): affected from 1.13.2; fixed in 1.13.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47271/ (Markdown: https://insights.sbomify.com/CVE-2025-47271/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47271
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47271
- OSV: https://osv.dev/vulnerability/CVE-2025-47271

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47271/
Summaries are generated and may contain mistakes; the official description above is the record.
