{"answers":{"affected":"2 open source packages ship an affected version, including auth0/auth0-php.","exploited":"There is no known exploitation of CVE-2025-47275 in the wild and no public exploit code.","fix":"Upgrade auth0/auth0-php to 8.14.0 or later.","what":"CVE-2025-47275 is a critical authentication bypass vulnerability in auth0-PHP, published on 15 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-47275 and fix it if it is affected.\n\nWhat it is: CVE-2025-47275 is a critical authentication bypass vulnerability in auth0-PHP, published on 15 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-47275 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/auth0-php (Packagist): affected from 8.0.0-BETA1; fixed in 8.14.0\n- auth0/auth0-php (Packagist): affected from 8.0.0-BETA1; fixed in 8.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-47275/ (Markdown: https://insights.sbomify.com/CVE-2025-47275/index.md)","id":"CVE-2025-47275","markdown":"https://insights.sbomify.com/CVE-2025-47275/index.md","name":"CVE-2025-47275","record":{"aliases":["GHSA-g98g-r7gf-2r25"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP Auth0 SDK","requires_auth":"none","summary":"Attackers can brute force authentication tags in CookieStore sessions to gain unauthorized access to applications using the Auth0-PHP SDK.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Auth0-PHP provides the PHP SDK for Auth0 Authentication and Management APIs. Starting in version 8.0.0-BETA1 and prior to version 8.14.0, session cookies of applications using the Auth0-PHP SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. Certain pre-conditions are required to be vulnerable to this issue: Applications using the Auth0-PHP SDK, or the Auth0/symfony, Auth0/laravel-auth0, and Auth0/wordpress SDKs that rely on the Auth0-PHP SDK; and session storage configured with CookieStore. Upgrade Auth0/Auth0-PHP to v8.14.0 to receive a patch. As an additional precautionary measure, rotating cookie encryption keys is recommended. Note that once updated, any previous session cookies will be rejected.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Brute Force Authentication Tags of CookieStore Sessions in Auth0-PHP SDK","id":"CVE-2025-47275","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":6,"next":{"headline":"Actualizer is a single shell script solution to allow developers and embedded engineers to create Debian operating systems (OS).","id":"CVE-2025-47276"},"packages":[{"ecosystem":"Packagist","fixed":["8.14.0"],"introduced":["8.0.0-BETA1"],"last_affected":[],"package":"auth0/auth0-php","purl":null,"source":"GHSA-g98g-r7gf-2r25"},{"ecosystem":"Packagist","fixed":["8.14.0"],"introduced":["8.0.0-BETA1"],"last_affected":[],"package":"auth0/auth0-php","purl":"pkg:composer/auth0/auth0-php","source":"GHSA-g98g-r7gf-2r25"}],"prev":{"headline":"ToolHive stores secrets in the state store with no encryption","id":"CVE-2025-47274"},"products":["auth0-PHP"],"published":"2025-05-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-22","vendors":["auth0"]},"summary":"Attackers can brute force authentication tags in CookieStore sessions to gain unauthorized access to applications using the Auth0-PHP SDK.","url":"https://insights.sbomify.com/CVE-2025-47275/"}