# CVE-2025-47275: Brute Force Authentication Tags of CookieStore Sessions in Auth0-PHP SDK

> Attackers can brute force authentication tags in CookieStore sessions to gain unauthorized access to applications using the Auth0-PHP SDK.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2025
- **Updated:** 22 May 2025
- **Also known as:** GHSA-g98g-r7gf-2r25

## What is CVE-2025-47275?

CVE-2025-47275 is a critical authentication bypass vulnerability in auth0-PHP, published on 15 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Auth0-PHP provides the PHP SDK for Auth0 Authentication and Management APIs. Starting in version 8.0.0-BETA1 and prior to version 8.14.0, session cookies of applications using the Auth0-PHP SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. Certain pre-conditions are required to be vulnerable to this issue: Applications using the Auth0-PHP SDK, or the Auth0/symfony, Auth0/laravel-auth0, and Auth0/wordpress SDKs that rely on the Auth0-PHP SDK; and session storage configured with CookieStore. Upgrade Auth0/Auth0-PHP to v8.14.0 to receive a patch. As an additional precautionary measure, rotating cookie encryption keys is recommended. Note that once updated, any previous session cookies will be rejected.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-47275?

2 open source packages ship an affected version, including auth0/auth0-php.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0/auth0-php` | Packagist | From 8.0.0-BETA1 | 8.14.0 |
| `auth0/auth0-php` | Packagist | From 8.0.0-BETA1 | 8.14.0 |

## How do I fix CVE-2025-47275?

Upgrade auth0/auth0-php to 8.14.0 or later.

## Is CVE-2025-47275 being exploited?

There is no known exploitation of CVE-2025-47275 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47275 and fix it if it is affected.

What it is: CVE-2025-47275 is a critical authentication bypass vulnerability in auth0-PHP, published on 15 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47275 in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0/auth0-php (Packagist): affected from 8.0.0-BETA1; fixed in 8.14.0
- auth0/auth0-php (Packagist): affected from 8.0.0-BETA1; fixed in 8.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47275/ (Markdown: https://insights.sbomify.com/CVE-2025-47275/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47275
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47275
- OSV: https://osv.dev/vulnerability/CVE-2025-47275

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47275/
Summaries are generated and may contain mistakes; the official description above is the record.
