{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-47276 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-47276 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-47276 is a high-severity vulnerability in ChewKeanHo Actualizer, published on 13 May 2025."},"fix_prompt":"Check this codebase for CVE-2025-47276 and fix it if it is affected.\n\nWhat it is: CVE-2025-47276 is a high-severity vulnerability in ChewKeanHo Actualizer, published on 13 May 2025. \nExploitation: There is no known exploitation of CVE-2025-47276 in the wild and no public exploit code.\n\nAffected product: ChewKeanHo Actualizer. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-47276/ (Markdown: https://insights.sbomify.com/CVE-2025-47276/index.md)","id":"CVE-2025-47276","markdown":"https://insights.sbomify.com/CVE-2025-47276/index.md","name":"CVE-2025-47276","record":{"aliases":["GHSA-v626-chv9-v9qr"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-328","name":"Use of Weak Hash"}],"description":"Actualizer is a single shell script solution to allow developers and embedded engineers to create Debian operating systems (OS). Prior to version 1.2.0, Actualizer uses OpenSSL's  \"-passwd\" function, which uses SHA512 instead of a more suitable password hasher like Yescript/Argon2i. All Actualizer users building a full Debian Operating System are affected. Users should upgrade to version 1.2.0 of Actualizer. Existing OS deployment requires manual password changes against the alpha and root accounts. The change will deploy's Debian's yescript overriding the older SHA512 hash created by OpenSSL. As a workaround, users need to reset both `root` and \"Alpha\" users' passwords.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Actualizer is a single shell script solution to allow developers and embedded engineers to create Debian operating systems (OS).","id":"CVE-2025-47276","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2025"},"n_packages":0,"n_references":7,"next":{"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277"},"packages":[],"prev":{"headline":"Brute Force Authentication Tags of CookieStore Sessions in Auth0-PHP SDK","id":"CVE-2025-47275"},"products":["Actualizer"],"published":"2025-05-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-13","vendors":["ChewKeanHo"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2025-47276/"}