# CVE-2025-47276: Actualizer is a single shell script solution to allow developers and embedded engineers to create Debian operating systems (OS).


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 13 May 2025
- **Updated:** 13 May 2025
- **Also known as:** GHSA-v626-chv9-v9qr

## What is CVE-2025-47276?

CVE-2025-47276 is a high-severity vulnerability in ChewKeanHo Actualizer, published on 13 May 2025. 

### Official description

Actualizer is a single shell script solution to allow developers and embedded engineers to create Debian operating systems (OS). Prior to version 1.2.0, Actualizer uses OpenSSL's  "-passwd" function, which uses SHA512 instead of a more suitable password hasher like Yescript/Argon2i. All Actualizer users building a full Debian Operating System are affected. Users should upgrade to version 1.2.0 of Actualizer. Existing OS deployment requires manual password changes against the alpha and root accounts. The change will deploy's Debian's yescript overriding the older SHA512 hash created by OpenSSL. As a workaround, users need to reset both `root` and "Alpha" users' passwords.

Weakness: CWE-328 (Use of Weak Hash)

## Which versions are affected by CVE-2025-47276?


## How do I fix CVE-2025-47276?

No fix has been published for CVE-2025-47276 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-47276 being exploited?

There is no known exploitation of CVE-2025-47276 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47276 and fix it if it is affected.

What it is: CVE-2025-47276 is a high-severity vulnerability in ChewKeanHo Actualizer, published on 13 May 2025. 
Exploitation: There is no known exploitation of CVE-2025-47276 in the wild and no public exploit code.

Affected product: ChewKeanHo Actualizer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47276/ (Markdown: https://insights.sbomify.com/CVE-2025-47276/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47276
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47276
- OSV: https://osv.dev/vulnerability/CVE-2025-47276

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47276/
Summaries are generated and may contain mistakes; the official description above is the record.
