# CVE-2025-47277: vLLM Allows Remote Code Execution via PyNcclPipe Communication Service

> Attackers can execute arbitrary code via unsafe deserialization in PyNcclPipe if exposed to untrusted networks.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2025
- **Updated:** 20 May 2025
- **Also known as:** GHSA-hjq4-87xh-g4fv, PYSEC-2026-567

## What is CVE-2025-47277?

CVE-2025-47277 is a critical unsafe deserialization vulnerability in Vllm Vllm, published on 20 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM, an inference and serving engine for large language models (LLMs), has an issue in versions 0.6.5 through 0.8.4 that ONLY impacts environments using the `PyNcclPipe` KV cache transfer integration with the V0 engine. No other configurations are affected. vLLM supports the use of the `PyNcclPipe` class to establish a peer-to-peer communication domain for data transmission between distributed nodes. The GPU-side KV-Cache transmission is implemented through the `PyNcclCommunicator` class, while CPU-side control message passing is handled via the `send_obj` and `recv_obj` methods on the CPU side.​ The intention was that this interface should only be exposed to a private network using the IP address specified by the `--kv-ip` CLI parameter. The vLLM documentation covers how this must be limited to a secured network. The default and intentional behavior from PyTorch is that the `TCPStore` interface listens on ALL interfaces, regardless of what IP address is provided. The IP address given was only used as a client-side address to use. vLLM was fixed to use a workaround to force the `TCPStore` instance to bind its socket to a specified private interface. As of version 0.8.5, vLLM limits the `TCPStore` socket to the private interface as configured.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-47277?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.6.5 | 0.8.5 |
| `vllm` | PyPI | From 0.6.5 | 0.8.5 |
| `vllm` | PyPI | From 0.6.5 | 0.8.5 |

Products: Vllm Vllm.

## How do I fix CVE-2025-47277?

Upgrade vllm to 0.8.5 or later.

## Is CVE-2025-47277 being exploited?

There is no known exploitation of CVE-2025-47277 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)
- [CVE-2025-29783](https://insights.sbomify.com/CVE-2025-29783/): vLLM Allows Remote Code Execution via Mooncake Integration (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47277 and fix it if it is affected.

What it is: CVE-2025-47277 is a critical unsafe deserialization vulnerability in Vllm Vllm, published on 20 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47277 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.6.5; fixed in 0.8.5
- vllm (PyPI): affected from 0.6.5; fixed in 0.8.5
- vllm (PyPI): affected from 0.6.5; fixed in 0.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47277/ (Markdown: https://insights.sbomify.com/CVE-2025-47277/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47277
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47277
- OSV: https://osv.dev/vulnerability/CVE-2025-47277

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47277/
Summaries are generated and may contain mistakes; the official description above is the record.
