{"answers":{"affected":"3 open source packages ship an affected version, including flask.","exploited":"There is no known exploitation of CVE-2025-47278 in the wild and no public exploit code.","fix":"Upgrade flask to 3.1.1 or later.","what":"CVE-2025-47278 is a low-severity vulnerability in pallets flask, published on 13 May 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-47278 and fix it if it is affected.\n\nWhat it is: CVE-2025-47278 is a low-severity vulnerability in pallets flask, published on 13 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-47278 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flask (PyPI): affected from 3.1.0; fixed in 3.1.1\n- flask (PyPI): affected from 3.1.0; fixed in 3.1.1\n- flask (PyPI): affected from 3.1.0; fixed in 3.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-47278/ (Markdown: https://insights.sbomify.com/CVE-2025-47278/index.md)","id":"CVE-2025-47278","markdown":"https://insights.sbomify.com/CVE-2025-47278/index.md","name":"CVE-2025-47278","record":{"aliases":["AZL-77828","AZL-77831","DEBIAN-CVE-2025-47278","ECHO-591b-96c8-dac8","GHSA-4grg-w6v8-c28g","PYSEC-2026-1377","USN-7534-1","openSUSE-SU-2025:15152-1"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Flask web framework","requires_auth":"high_privilege","summary":"Flask incorrectly uses stale fallback keys for session signing when key rotation is enabled, potentially impeding secure key transitions.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":1.8,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-683","name":"Function Call With Incorrect Order of Arguments"}],"description":"Flask is a web server gateway interface (WSGI) web application framework. In Flask 3.1.0, the way fallback key configuration was handled resulted in the last fallback key being used for signing, rather than the current signing key. Signing is provided by the `itsdangerous` library. A list of keys can be passed, and it expects the last (top) key in the list to be the most recent key, and uses that for signing. Flask was incorrectly constructing that list in reverse, passing the signing key first. Sites that have opted-in to use key rotation by setting `SECRET_KEY_FALLBACKS` care likely to unexpectedly be signing their sessions with stale keys, and their transition to fresher keys will be impeded. Sessions are still signed, so this would not cause any sort of data integrity loss. Version 3.1.1 contains a patch for the issue.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Flask uses fallback key instead of current signing key","id":"CVE-2025-47278","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"undici Denial of Service attack via bad certificate data","id":"CVE-2025-47279"},"packages":[{"ecosystem":"PyPI","fixed":["3.1.1"],"introduced":["3.1.0"],"last_affected":[],"package":"flask","purl":null,"source":"GHSA-4grg-w6v8-c28g"},{"ecosystem":"PyPI","fixed":["3.1.1"],"introduced":["3.1.0"],"last_affected":[],"package":"flask","purl":"pkg:pypi/flask","source":"GHSA-4grg-w6v8-c28g"},{"ecosystem":"PyPI","fixed":["3.1.1"],"introduced":["3.1.0"],"last_affected":[],"package":"flask","purl":"pkg:pypi/flask","source":"PYSEC-2026-1377"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.1.1-1.1"],"introduced":["0"],"last_affected":[],"package":"python-Flask","purl":"pkg:rpm/opensuse/python-Flask\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15152-1"}],"prev":{"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277"},"products":["flask"],"published":"2025-05-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-13","vendors":["pallets"]},"summary":"Flask incorrectly uses stale fallback keys for session signing when key rotation is enabled, potentially impeding secure key transitions.","url":"https://insights.sbomify.com/CVE-2025-47278/"}