CVE-2025-47279 undici Denial of Service attack via bad certificate data
Attackers can cause memory leaks and denial of service in Node.js applications using undici by forcing repeated calls to servers with invalid certificates.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-47279?
CVE-2025-47279 is a low-severity denial of service vulnerability in nodejs undici, published on 15 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Undici is an HTTP/1.1 client for Node.js. Prior to versions 5.29.0, 6.21.2, and 7.5.0, applications that use undici to implement a webhook-like system are vulnerable. If the attacker set up a server with an invalid certificate, and they can force the application to call the webhook repeatedly, then they can cause a memory leak. This has been patched in versions 5.29.0, 6.21.2, and 7.5.0. As a workaound, avoid calling a webhook repeatedly if the webhook fails.
Weakness: CWE-401
Which versions are affected by CVE-2025-47279?
6 open source packages ship an affected version, including undici.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | All versions | 5.29.0 |
undici npm | All versions | 5.29.0 |
undici npm | From 6.0.0 | 6.21.2 |
undici npm | From 6.0.0 | 6.21.2 |
undici npm | From 7.0.0 | 7.5.0 |
undici npm | From 7.0.0 | 7.5.0 |
How do I fix CVE-2025-47279?
Upgrade undici to a fixed version for your release line: 5.29.0, 6.21.2 or 7.5.0.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-47279 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47279 exists.
Sources
Also known as AZL-61895, AZL-61897, DEBIAN-CVE-2025-47279, ECHO-f635-511d-b439, GHSA-cxrh-j4jr-qwg3, MINI-89qf-c3m7-pr5x and 5 more.