# CVE-2025-47280: Umbraco.Forms has HTML injection vulnerability in 'Send email' workflow

> Attackers can inject HTML into emails sent by Umbraco Forms, potentially bypassing spam filters and email client security controls.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:H/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 May 2025
- **Updated:** 13 May 2025
- **Also known as:** GHSA-2qrj-g9hq-chph

## What is CVE-2025-47280?

CVE-2025-47280 is a low-severity cross-site scripting vulnerability in Umbraco.Forms.Issues, published on 13 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Umbraco Forms is a form builder that integrates with the Umbraco content management system. Starting in the 7.x branch and prior to versions 13.4.2 and 15.1.2, the 'Send email' workflow does not HTML encode the user-provided field values in the sent email message, making any form with this workflow configured vulnerable, as it allows sending the message from a trusted system and address, potentially bypassing spam and email client security systems. This issue affects all (supported) versions Umbraco Forms and is patched in 13.4.2 and 15.1.2. Unpatched or unsupported versions can workaround this issue by using the `Send email with template (Razor)` workflow instead or writing a custom workflow type. To avoid accidentally using the vulnerable workflow again, the `SendEmail` workflow type can be removed using a composer available in the GitHub Security Advisory for this vulnerability.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2025-47280?

6 open source packages ship an affected version, including Umbraco.Forms and UmbracoForms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Umbraco.Forms` | NuGet | From 14.0.0 | 15.1.2 |
| `Umbraco.Forms` | NuGet | From 14.0.0 | 15.1.2 |
| `Umbraco.Forms` | NuGet | From 7.0.0 | 13.4.2 |
| `Umbraco.Forms` | NuGet | From 7.0.0 | 13.4.2 |
| `UmbracoForms` | NuGet | From 7.0.0 to 8.13.16 | None |
| `UmbracoForms` | NuGet | From 7.0.0 to 8.13.16 | None |

Products: Umbraco Umbraco Forms.

## How do I fix CVE-2025-47280?

Upgrade Umbraco.Forms to a fixed version for your release line: 15.1.2 or 13.4.2.

## Is CVE-2025-47280 being exploited?

There is no known exploitation of CVE-2025-47280 in the wild and no public exploit code.

## Other vulnerabilities in Umbraco.Forms.Issues

- [CVE-2021-33224](https://insights.sbomify.com/CVE-2021-33224/): File upload in n/a (critical 9.8)
- [CVE-2025-68924](https://insights.sbomify.com/CVE-2025-68924/): UmbracoForms Vulnerable to Remote Code Execution via Untrusted WSDL Compilation in Dynamic SOAP Client Generation (high 7.5)
- [CVE-2026-24687](https://insights.sbomify.com/CVE-2026-24687/): Umbraco.Forms has path traversal and file enumeration vulnerability in Linux/Mac (medium 6.0)
- [CVE-2025-23041](https://insights.sbomify.com/CVE-2025-23041/): Short and Long Answer Fields Are Not Validated Server-Side For Maximum Length in Umbraco.Forms (medium 5.8)
- [CVE-2020-7685](https://insights.sbomify.com/CVE-2020-7685/): Insecure Defaults (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47280 and fix it if it is affected.

What it is: CVE-2025-47280 is a low-severity cross-site scripting vulnerability in Umbraco.Forms.Issues, published on 13 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-47280 in the wild and no public exploit code.

Affected packages and fixed versions:
- Umbraco.Forms (NuGet): affected from 14.0.0; fixed in 15.1.2
- Umbraco.Forms (NuGet): affected from 14.0.0; fixed in 15.1.2
- Umbraco.Forms (NuGet): affected from 7.0.0; fixed in 13.4.2
- Umbraco.Forms (NuGet): affected from 7.0.0; fixed in 13.4.2
- UmbracoForms (NuGet): affected from 7.0.0 up to 8.13.16; no fix listed
- UmbracoForms (NuGet): affected from 7.0.0 up to 8.13.16; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47280/ (Markdown: https://insights.sbomify.com/CVE-2025-47280/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47280
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47280
- OSV: https://osv.dev/vulnerability/CVE-2025-47280

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47280/
Summaries are generated and may contain mistakes; the official description above is the record.
