# CVE-2025-47281: Kyverno's Improper JMESPath Variable Evaluation Leads to Denial of Service

> Attackers with policy creation permissions can crash Kyverno admission and report controllers by crafting invalid JMESPath expressions, causing a denial of service.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jul 2025
- **Updated:** 23 Jul 2025
- **Also known as:** BIT-kyverno-2025-47281, CLEANSTART-2026-JI50806, CLEANSTART-2026-OT05000, GHSA-r5p3-955p-5ggq, GO-2025-3823, MINI-4j32-w427-fhgg, MINI-9pqm-h4f2-vm78, MINI-9w44-862c-gc38, MINI-9wm6-v86r-j2p4, MINI-jp44-6xhj-frqc, MINI-p8jf-757q-j94x, MINI-qhmr-phx3-xqg4

## What is CVE-2025-47281?

CVE-2025-47281 is a high-severity denial of service vulnerability in kyverno, published on 23 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kyverno is a policy engine designed for cloud native platform engineering teams. In versions 1.14.1 and below, a Denial of Service (DoS) vulnerability exists due to improper handling of JMESPath variable substitutions. Attackers with permissions to create or update Kyverno policies can craft expressions using the {{@}} variable combined with a pipe and an invalid JMESPath function (e.g., {{@ | non_existent_function }}). This leads to a nil value being substituted into the policy structure. Subsequent processing by internal functions, specifically getValueAsStringMap, which expect string values, results in a panic due to a type assertion failure (interface {} is nil, not string). This crashes Kyverno worker threads in the admission controller and causes continuous crashes of the reports controller pod. This is fixed in version 1.14.2.

Weakness: CWE-248 (Uncaught Exception), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-47281?

4 open source packages ship an affected version, including github.com/kyverno/kyverno and kyverno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kyverno/kyverno` | Go | All versions | 1.14.2 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.14.2 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.14.2 |
| `kyverno` | Bitnami | All versions | 1.14.2 |

Products: Kyverno Kyverno.

## How do I fix CVE-2025-47281?

Upgrade github.com/kyverno/kyverno to 1.14.2 or later.

## Is CVE-2025-47281 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47281 exists.

## Other vulnerabilities in kyverno

- [CVE-2026-22039](https://insights.sbomify.com/CVE-2026-22039/): Kyverno Cross-Namespace Privilege Escalation via Policy apiCall (critical 10.0)
- [CVE-2026-4789](https://insights.sbomify.com/CVE-2026-4789/): CVE-2026-4789 (critical 9.8)
- [CVE-2025-46342](https://insights.sbomify.com/CVE-2025-46342/): Kyverno vulnerable to bypass of policy rules that use namespace selectors in match statements (high 8.6)
- [CVE-2026-41323](https://insights.sbomify.com/CVE-2026-41323/): Kyverno: ServiceAccount token leaked to external servers via apiCall service URL (high 8.1)
- [CVE-2026-40868](https://insights.sbomify.com/CVE-2026-40868/): kyverno apicall servicecall implicit bearer token injection leaks kyverno serviceaccount token (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47281 and fix it if it is affected.

What it is: CVE-2025-47281 is a high-severity denial of service vulnerability in kyverno, published on 23 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47281 exists.

Affected packages and fixed versions:
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.14.2
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.14.2
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.14.2
- kyverno (Bitnami): affected all versions; fixed in 1.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47281/ (Markdown: https://insights.sbomify.com/CVE-2025-47281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47281
- OSV: https://osv.dev/vulnerability/CVE-2025-47281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47281/
Summaries are generated and may contain mistakes; the official description above is the record.
