# CVE-2025-47282: Malicious google credential in DNS secret can lead to privilege escalation

> Administrative users in Gardener projects or shoot clusters can escalate privileges to control the underlying seed cluster via malicious DNS credentials.

- **Severity:** Critical 9.9 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2025
- **Updated:** 20 May 2025
- **Also known as:** GHSA-xwgg-m7fx-83wx, GO-2025-3697

## What is CVE-2025-47282?

CVE-2025-47282 is a critical vulnerability in gardener external-dns-management, published on 19 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gardener External DNS Management is an environment to manage external DNS entries for a kubernetes cluster. A security vulnerability was discovered in Gardener's External DNS Management prior to version 0.23.6 that could allow a user with administrative privileges for a Gardener project or a user with administrative privileges for a shoot cluster, including administrative privileges for a single namespace of the shoot cluster, to obtain control over the seed cluster where the shoot cluster is managed. This CVE affects all Gardener installations no matter of the public cloud provider(s) used for the seed clusters/shoot clusters. The affected component is `gardener/external-dns-management`. The `external-dns-management` component may also be deployed on the seeds by the `gardener/gardener-extension-shoot-dns-service` extension when the extension is enabled. In this case, all versions of the `shoot-dns-service` extension `<= v1.60.0` are affected by this vulnerability. Version 0.23.6 of Gardener External DNS Management fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-47282?

6 open source packages ship an affected version, including github.com/gardener/external-dns-management and github.com/gardener/gardener-extension-shoot-dns-service.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gardener/external-dns-management` | Go | All versions | 0.23.6 |
| `github.com/gardener/external-dns-management` | Go | All versions | 0.23.6 |
| `github.com/gardener/external-dns-management` | Go | All versions | 0.23.6 |
| `github.com/gardener/gardener-extension-shoot-dns-service` | Go | All versions | None |
| `github.com/gardener/gardener-extension-shoot-dns-service` | Go | All versions to 1.6.0 | None |
| `github.com/gardener/gardener-extension-shoot-dns-service` | Go | All versions to 1.6.0 | None |

## How do I fix CVE-2025-47282?

Upgrade github.com/gardener/external-dns-management to 0.23.6 or later.

## Is CVE-2025-47282 being exploited?

There is no known exploitation of CVE-2025-47282 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47282 and fix it if it is affected.

What it is: CVE-2025-47282 is a critical vulnerability in gardener external-dns-management, published on 19 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47282 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/gardener/external-dns-management (Go): affected all versions; fixed in 0.23.6
- github.com/gardener/external-dns-management (Go): affected all versions; fixed in 0.23.6
- github.com/gardener/external-dns-management (Go): affected all versions; fixed in 0.23.6
- github.com/gardener/gardener-extension-shoot-dns-service (Go): affected all versions; no fix listed
- github.com/gardener/gardener-extension-shoot-dns-service (Go): affected all versions up to 1.6.0; no fix listed
- github.com/gardener/gardener-extension-shoot-dns-service (Go): affected all versions up to 1.6.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47282/ (Markdown: https://insights.sbomify.com/CVE-2025-47282/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47282
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47282
- OSV: https://osv.dev/vulnerability/CVE-2025-47282

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47282/
Summaries are generated and may contain mistakes; the official description above is the record.
