# CVE-2025-47283: Bypassing project secret validation can lead to privilege escalation

> A user with project admin privileges can bypass secret validation to gain control over the underlying seed cluster, requiring an upgrade to patched versions.

- **Severity:** Critical 9.9 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2025
- **Updated:** 6 Feb 2026
- **Also known as:** GHSA-3hw7-qj9h-r835, GO-2025-3696

## What is CVE-2025-47283?

CVE-2025-47283 is a critical vulnerability in gardener, published on 19 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gardener implements the automated management and operation of Kubernetes clusters as a service. A security vulnerability was discovered in Gardener prior to versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0 that could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster(s) where their shoot clusters are managed. This CVE affects all Gardener installations no matter of the public cloud provider(s) used for the seed clusters/shoot clusters. `gardener/gardener` (`gardenlet`) is the affected component. Versions 1.116.4, 1.117.5, 1.118.2, and 1.119.0 fix the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-47283?

7 open source packages ship an affected version, including github.com/gardener/gardener. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gardener/gardener` | Go | All versions | 1.116.4, 1.117.5, 1.118.2 |
| `github.com/gardener/gardener` | Go | All versions | 1.116.4 |
| `github.com/gardener/gardener` | Go | All versions | 1.116.4 |
| `github.com/gardener/gardener` | Go | From 1.117.0 | 1.117.5 |
| `github.com/gardener/gardener` | Go | From 1.117.0 | 1.117.5 |
| `github.com/gardener/gardener` | Go | From 1.118.0 | 1.118.2 |
| `github.com/gardener/gardener` | Go | From 1.118.0 | 1.118.2 |

Products: Gardener Gardener.

## How do I fix CVE-2025-47283?

Upgrade github.com/gardener/gardener to a fixed version for your release line: 1.116.4, 1.117.5 or 1.118.2.

## Is CVE-2025-47283 being exploited?

There is no known exploitation of CVE-2025-47283 in the wild and no public exploit code.

## Other vulnerabilities in gardener

- [CVE-2025-47284](https://insights.sbomify.com/CVE-2025-47284/): Gardener vulnerable to metadata injection for a project secret that can lead to privilege escalation (critical 9.9)
- [CVE-2019-12494](https://insights.sbomify.com/CVE-2019-12494/): Missing authorization in n/a (high 8.5)
- [CVE-2018-2475](https://insights.sbomify.com/CVE-2018-2475/): Missing authorization in project “Gardener” (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47283 and fix it if it is affected.

What it is: CVE-2025-47283 is a critical vulnerability in gardener, published on 19 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47283 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/gardener/gardener (Go): affected all versions; fixed in 1.116.4, 1.117.5, 1.118.2
- github.com/gardener/gardener (Go): affected all versions; fixed in 1.116.4
- github.com/gardener/gardener (Go): affected all versions; fixed in 1.116.4
- github.com/gardener/gardener (Go): affected from 1.117.0; fixed in 1.117.5
- github.com/gardener/gardener (Go): affected from 1.117.0; fixed in 1.117.5
- github.com/gardener/gardener (Go): affected from 1.118.0; fixed in 1.118.2
- github.com/gardener/gardener (Go): affected from 1.118.0; fixed in 1.118.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47283/ (Markdown: https://insights.sbomify.com/CVE-2025-47283/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47283
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47283
- OSV: https://osv.dev/vulnerability/CVE-2025-47283

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47283/
Summaries are generated and may contain mistakes; the official description above is the record.
