# CVE-2025-47288: Discourse Policy plugin private group members visible

> Attackers can view members of private groups if policies are posted to public topics, exposing sensitive membership data.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 29 May 2025
- **Updated:** 30 May 2025
- **Also known as:** GHSA-jc5r-rm2j-mh4x

## What is CVE-2025-47288?

CVE-2025-47288 is a low-severity vulnerability in discourse-policy, published on 29 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Discourse Policy plugin gives the ability to confirm users have seen or done something. Prior to version 0.1.1, if there was a policy posted to a public topic that was tied to a private group then the group members could be shown to non-group members. This issue has been patched in version 0.1.1. A workaround involves moving any policy topics with private groups to restricted categories.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-47288?


## How do I fix CVE-2025-47288?

No fix has been published for CVE-2025-47288 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-47288 being exploited?

There is no known exploitation of CVE-2025-47288 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47288 and fix it if it is affected.

What it is: CVE-2025-47288 is a low-severity vulnerability in discourse-policy, published on 29 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-47288 in the wild and no public exploit code.

Affected product: discourse-policy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47288/ (Markdown: https://insights.sbomify.com/CVE-2025-47288/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47288
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47288
- OSV: https://osv.dev/vulnerability/CVE-2025-47288

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47288/
Summaries are generated and may contain mistakes; the official description above is the record.
