CVE-2025-47290 Containerd vulnerable to host filesystem access during image unpack

High 7.6 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2025-47290?

CVE-2025-47290 is a high-severity vulnerability in containerd, published on 20 May 2025.

Official description

containerd is a container runtime. A time-of-check to time-of-use (TOCTOU) vulnerability was found in containerd v2.1.0. While unpacking an image during an image pull, specially crafted container images could arbitrarily modify the host file system. The only affected version of containerd is 2.1.0. Other versions of containerd are not affected. This bug has been fixed in containerd 2.1.1. Users should update to this version to resolve the issue. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.

Weakness: CWE-367

Which versions are affected by CVE-2025-47290?

3 open source packages ship an affected version, including github.com/containerd/containerd/v2. It affects 1 product.

PackageAffectedFixed in
github.com/containerd/containerd/v2 GoFrom 2.1.02.1.1
github.com/containerd/containerd/v2 GoFrom 2.1.02.1.1
github.com/containerd/containerd/v2 GoFrom 2.1.02.1.1
Linux distribution packages (1)
kind openSUSE:TumbleweedAll versions0.29.0-1.1

Products include Linuxfoundation Containerd.

How do I fix CVE-2025-47290?

Upgrade github.com/containerd/containerd/v2 to 2.1.1 or later.

Is CVE-2025-47290 being exploited?

There is no known exploitation of CVE-2025-47290 in the wild and no public exploit code.

Sources

Also known as BELL-CVE-2025-47290, GHSA-cm76-qm8v-3j95, GO-2025-3699, MINI-65jq-g62h-p52c, openSUSE-SU-2025:15146-1.

Is CVE-2025-47290 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free