# CVE-2025-47291: containerd CRI plugin: Incorrect cgroup hierarchy assignment for containers running in usernamespaced Kubernetes pods.

> Attackers can cause denial of service on Kubernetes nodes by exploiting incorrect cgroup assignments in usernamespaced containers.

- **Severity:** Medium 4.6 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2025
- **Updated:** 21 May 2025
- **Also known as:** AZL-62003, GHSA-cxfp-7pvr-95ff, GO-2025-3701, MINI-mr8c-4jmc-7x8w, UBUNTU-CVE-2025-47291

## What is CVE-2025-47291?

CVE-2025-47291 is a medium-severity vulnerability in containerd, published on 21 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

containerd is an open-source container runtime. A bug was found in the containerd's CRI implementation where containerd, starting in version 2.0.1 and prior to version 2.0.5, doesn't put usernamespaced containers under the Kubernetes' cgroup hierarchy, therefore some Kubernetes limits are not honored. This may cause a denial of service of the Kubernetes node. This bug has been fixed in containerd 2.0.5+ and 2.1.0+. Users should update to these versions to resolve the issue. As a workaround, disable usernamespaced pods in Kubernetes temporarily.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-47291?

3 open source packages ship an affected version, including github.com/containerd/containerd/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containerd/containerd/v2` | Go | From 2.0.1 | 2.0.5 |
| `github.com/containerd/containerd/v2` | Go | From 2.0.1 | 2.0.5 |
| `github.com/containerd/containerd/v2` | Go | From 2.0.1 | 2.0.5 |

Products: Linuxfoundation Containerd.

## How do I fix CVE-2025-47291?

Upgrade github.com/containerd/containerd/v2 to 2.0.5 or later.

## Is CVE-2025-47291 being exploited?

There is no known exploitation of CVE-2025-47291 in the wild and no public exploit code.

## Other vulnerabilities in containerd

- [CVE-2026-53488](https://insights.sbomify.com/CVE-2026-53488/): containerd CRI — image-config `LABEL` flows to restart-monitor `binary://` logger: host-root command execution from an image pull (critical 9.4)
- [CVE-2026-53492](https://insights.sbomify.com/CVE-2026-53492/): containerd CRI checkpoint restore CDI annotation smuggling (high 8.4)
- [CVE-2026-53489](https://insights.sbomify.com/CVE-2026-53489/): containerd: Arbitrary host CRI log file read via symlink following in CRI checkpoint restore (high 8.2)
- [CVE-2025-47290](https://insights.sbomify.com/CVE-2025-47290/): Containerd vulnerable to host filesystem access during image unpack (high 7.6)
- [CVE-2026-46680](https://insights.sbomify.com/CVE-2026-46680/): containerd user ID handling bypass allows runAsNonRoot evasion (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47291 and fix it if it is affected.

What it is: CVE-2025-47291 is a medium-severity vulnerability in containerd, published on 21 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47291 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containerd/containerd/v2 (Go): affected from 2.0.1; fixed in 2.0.5
- github.com/containerd/containerd/v2 (Go): affected from 2.0.1; fixed in 2.0.5
- github.com/containerd/containerd/v2 (Go): affected from 2.0.1; fixed in 2.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47291/ (Markdown: https://insights.sbomify.com/CVE-2025-47291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47291
- OSV: https://osv.dev/vulnerability/CVE-2025-47291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47291/
Summaries are generated and may contain mistakes; the official description above is the record.
