{"answers":{"affected":"2 open source packages ship an affected version, including com.powsybl:powsybl-commons.","exploited":"There is no known exploitation of CVE-2025-47293 in the wild and no public exploit code.","fix":"Upgrade com.powsybl:powsybl-commons to 6.7.2 or later.","what":"CVE-2025-47293 is a low-severity vulnerability in powsybl-core, published on 19 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-47293 and fix it if it is affected.\n\nWhat it is: CVE-2025-47293 is a low-severity vulnerability in powsybl-core, published on 19 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-47293 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.powsybl:powsybl-commons (Maven): affected all versions; fixed in 6.7.2\n- com.powsybl:powsybl-commons (Maven): affected all versions; fixed in 6.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-47293/ (Markdown: https://insights.sbomify.com/CVE-2025-47293/index.md)","id":"CVE-2025-47293","markdown":"https://insights.sbomify.com/CVE-2025-47293/index.md","name":"CVE-2025-47293","record":{"aliases":["GHSA-qpj9-qcwx-8jv2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PowSyBl Core library","requires_auth":"none","summary":"Attackers can exploit XML parsing flaws to read sensitive files and perform server-side requests, impacting multi-tenant power system applications.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.7,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"PowSyBl (Power System Blocks) is a framework to build power system oriented software. Prior to version 6.7.2, in certain places, powsybl-core XML parsing is vulnerable to an XML external entity (XXE) attack and to a server-side request forgery (SSRF) attack. This allows an attacker to elevate their privileges to read files that they do not have permissions to, including sensitive files on the system. The vulnerable class is com.powsybl.commons.xml.XmlReader which is considered to be untrusted in use cases where untrusted users can submit their XML to the vulnerable methods. This can be a multi-tenant application that hosts many different users perhaps with different privilege levels. This issue has been patched in com.powsybl:powsybl-commons: 6.7.2.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PowSyBl Core XML Reader allows XXE and SSRF","id":"CVE-2025-47293","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Integer overflow in FortiOS","id":"CVE-2025-47294"},"packages":[{"ecosystem":"Maven","fixed":["6.7.2"],"introduced":["0"],"last_affected":[],"package":"com.powsybl:powsybl-commons","purl":null,"source":"GHSA-qpj9-qcwx-8jv2"},{"ecosystem":"Maven","fixed":["6.7.2"],"introduced":["0"],"last_affected":[],"package":"com.powsybl:powsybl-commons","purl":"pkg:maven/com.powsybl/powsybl-commons","source":"GHSA-qpj9-qcwx-8jv2"}],"prev":{"headline":"Cap Collectif vulnerable to insecure deserialization leading to remote code execution","id":"CVE-2025-47292"},"products":["powsybl-core"],"published":"2025-06-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-20","vendors":["powsybl"]},"summary":"Attackers can exploit XML parsing flaws to read sensitive files and perform server-side requests, impacting multi-tenant power system applications.","url":"https://insights.sbomify.com/CVE-2025-47293/"}