# CVE-2025-47293: PowSyBl Core XML Reader allows XXE and SSRF

> Attackers can exploit XML parsing flaws to read sensitive files and perform server-side requests, impacting multi-tenant power system applications.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2025
- **Updated:** 20 Jun 2025
- **Also known as:** GHSA-qpj9-qcwx-8jv2

## What is CVE-2025-47293?

CVE-2025-47293 is a low-severity vulnerability in powsybl-core, published on 19 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PowSyBl (Power System Blocks) is a framework to build power system oriented software. Prior to version 6.7.2, in certain places, powsybl-core XML parsing is vulnerable to an XML external entity (XXE) attack and to a server-side request forgery (SSRF) attack. This allows an attacker to elevate their privileges to read files that they do not have permissions to, including sensitive files on the system. The vulnerable class is com.powsybl.commons.xml.XmlReader which is considered to be untrusted in use cases where untrusted users can submit their XML to the vulnerable methods. This can be a multi-tenant application that hosts many different users perhaps with different privilege levels. This issue has been patched in com.powsybl:powsybl-commons: 6.7.2.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2025-47293?

2 open source packages ship an affected version, including com.powsybl:powsybl-commons.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.powsybl:powsybl-commons` | Maven | All versions | 6.7.2 |
| `com.powsybl:powsybl-commons` | Maven | All versions | 6.7.2 |

## How do I fix CVE-2025-47293?

Upgrade com.powsybl:powsybl-commons to 6.7.2 or later.

## Is CVE-2025-47293 being exploited?

There is no known exploitation of CVE-2025-47293 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47293 and fix it if it is affected.

What it is: CVE-2025-47293 is a low-severity vulnerability in powsybl-core, published on 19 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47293 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.powsybl:powsybl-commons (Maven): affected all versions; fixed in 6.7.2
- com.powsybl:powsybl-commons (Maven): affected all versions; fixed in 6.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47293/ (Markdown: https://insights.sbomify.com/CVE-2025-47293/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47293
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47293
- OSV: https://osv.dev/vulnerability/CVE-2025-47293

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47293/
Summaries are generated and may contain mistakes; the official description above is the record.
