CVE-2025-47410 Apache Geode: CSRF attacks through GET requests to the Management and Monitoring REST API that can execute gfsh commands on the target system

High 8.8 Published Updated

Attackers can execute arbitrary commands on Apache Geode systems by tricking authenticated users into visiting malicious links via CSRF.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-47410?

CVE-2025-47410 is a high-severity vulnerability in Apache Geode, published on 18 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Apache Geode is vulnerable to CSRF attacks through GET requests to the Management and Monitoring REST API that could allow an attacker who has tricked a user into giving up their Geode session credentials to submit malicious commands on the target system on behalf of the authenticated user.

This issue affects Apache Geode: versions 1.10 through 1.15.1

Users are recommended to upgrade to version 1.15.2, which fixes the issue.

Weakness: CWE-352

Which versions are affected by CVE-2025-47410?

2 open source packages ship an affected version, including org.apache.geode:geode-web. It affects 1 product.

PackageAffectedFixed in
org.apache.geode:geode-web MavenFrom 1.10.01.15.2
org.apache.geode:geode-web MavenFrom 1.10.01.15.2

Products include Apache Geode.

How do I fix CVE-2025-47410?

Upgrade org.apache.geode:geode-web to 1.15.2 or later.

Is CVE-2025-47410 being exploited?

There is no known exploitation of CVE-2025-47410 in the wild and no public exploit code.

Sources

Also known as GHSA-gjp8-99fv-cgcw.

Is CVE-2025-47410 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free