{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.geode:geode-web. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-47410 in the wild and no public exploit code.","fix":"Upgrade org.apache.geode:geode-web to 1.15.2 or later.","what":"CVE-2025-47410 is a high-severity vulnerability in Apache Geode, published on 18 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-47410 and fix it if it is affected.\n\nWhat it is: CVE-2025-47410 is a high-severity vulnerability in Apache Geode, published on 18 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-47410 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.geode:geode-web (Maven): affected from 1.10.0; fixed in 1.15.2\n- org.apache.geode:geode-web (Maven): affected from 1.10.0; fixed in 1.15.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-47410/ (Markdown: https://insights.sbomify.com/CVE-2025-47410/index.md)","id":"CVE-2025-47410","markdown":"https://insights.sbomify.com/CVE-2025-47410/index.md","name":"CVE-2025-47410","record":{"aliases":["GHSA-gjp8-99fv-cgcw"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Geode","requires_auth":"none","summary":"Attackers can execute arbitrary commands on Apache Geode systems by tricking authenticated users into visiting malicious links via CSRF.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"geode","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Apache Geode is vulnerable to CSRF attacks through GET requests to the Management and Monitoring REST API that could allow an attacker who has tricked a user into giving up their Geode session credentials to submit malicious commands on the target system on behalf of the authenticated user.\n\nThis issue affects Apache Geode: versions 1.10 through 1.15.1\n\nUsers are recommended to upgrade to version 1.15.2, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Geode: CSRF attacks through GET requests to the Management and Monitoring REST API that can execute gfsh commands on the target system","id":"CVE-2025-47410","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Apache StreamPipes: Leverage of User ID for Privilege Escalation","id":"CVE-2025-47411"},"packages":[{"ecosystem":"Maven","fixed":["1.15.2"],"introduced":["1.10.0"],"last_affected":[],"package":"org.apache.geode:geode-web","purl":null,"source":"GHSA-gjp8-99fv-cgcw"},{"ecosystem":"Maven","fixed":["1.15.2"],"introduced":["1.10.0"],"last_affected":[],"package":"org.apache.geode:geode-web","purl":"pkg:maven/org.apache.geode/geode-web","source":"GHSA-gjp8-99fv-cgcw"}],"prev":{"headline":"Untrusted Pointer Dereference in Power Optimization Firmware","id":"CVE-2025-47408"},"products":["Apache Geode"],"published":"2025-10-18","related":[{"cvss_score":9.8,"headline":"Apache Tomcat Improper Privilege Management","id":"CVE-2020-1938","kev_date_added":"2022-03-03","published":"2020-02-24"},{"cvss_score":7.8,"headline":"Docker Desktop Community Edition Privilege Escalation","id":"CVE-2019-15752","kev_date_added":"2021-11-03","published":"2019-08-28"},{"cvss_score":9.8,"headline":"Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8.","id":"CVE-2022-37021","kev_date_added":null,"published":"2022-08-31"},{"cvss_score":9.8,"headline":"Supply chain in docker.io","id":"CVE-2014-0048","kev_date_added":null,"published":"2020-01-02"},{"cvss_score":9.8,"headline":"Apache Geode unsafe deserialization in TcpServer","id":"CVE-2017-15692","kev_date_added":null,"published":"2018-02-27"},{"cvss_score":8.8,"headline":"Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 11","id":"CVE-2022-37022","kev_date_added":null,"published":"2022-08-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary commands on Apache Geode systems by tricking authenticated users into visiting malicious links via CSRF.","url":"https://insights.sbomify.com/CVE-2025-47410/"}