# CVE-2025-47410: Apache Geode: CSRF attacks through GET requests to the Management and Monitoring REST API that can execute gfsh commands on the target system

> Attackers can execute arbitrary commands on Apache Geode systems by tricking authenticated users into visiting malicious links via CSRF.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Oct 2025
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-gjp8-99fv-cgcw

## What is CVE-2025-47410?

CVE-2025-47410 is a high-severity vulnerability in Apache Geode, published on 18 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Apache Geode is vulnerable to CSRF attacks through GET requests to the Management and Monitoring REST API that could allow an attacker who has tricked a user into giving up their Geode session credentials to submit malicious commands on the target system on behalf of the authenticated user.

This issue affects Apache Geode: versions 1.10 through 1.15.1

Users are recommended to upgrade to version 1.15.2, which fixes the issue.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-47410?

2 open source packages ship an affected version, including org.apache.geode:geode-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.geode:geode-web` | Maven | From 1.10.0 | 1.15.2 |
| `org.apache.geode:geode-web` | Maven | From 1.10.0 | 1.15.2 |

Products: Apache Geode.

## How do I fix CVE-2025-47410?

Upgrade org.apache.geode:geode-web to 1.15.2 or later.

## Is CVE-2025-47410 being exploited?

There is no known exploitation of CVE-2025-47410 in the wild and no public exploit code.

## Other vulnerabilities in Apache Geode

- [CVE-2020-1938](https://insights.sbomify.com/CVE-2020-1938/): Apache Tomcat Improper Privilege Management (critical 9.8, exploited in the wild)
- [CVE-2019-15752](https://insights.sbomify.com/CVE-2019-15752/): Docker Desktop Community Edition Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2022-37021](https://insights.sbomify.com/CVE-2022-37021/): Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8. (critical 9.8)
- [CVE-2014-0048](https://insights.sbomify.com/CVE-2014-0048/): Supply chain in docker.io (critical 9.8)
- [CVE-2017-15692](https://insights.sbomify.com/CVE-2017-15692/): Apache Geode unsafe deserialization in TcpServer (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47410 and fix it if it is affected.

What it is: CVE-2025-47410 is a high-severity vulnerability in Apache Geode, published on 18 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-47410 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.geode:geode-web (Maven): affected from 1.10.0; fixed in 1.15.2
- org.apache.geode:geode-web (Maven): affected from 1.10.0; fixed in 1.15.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47410/ (Markdown: https://insights.sbomify.com/CVE-2025-47410/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47410
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47410
- OSV: https://osv.dev/vulnerability/CVE-2025-47410

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47410/
Summaries are generated and may contain mistakes; the official description above is the record.
