CVE-2025-47411 Apache StreamPipes: Leverage of User ID for Privilege Escalation

High 8.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2025-47411?

CVE-2025-47411 is a high-severity vulnerability in Apache StreamPipes, published on 1 Jan 2026.

Official description

A user with a legitimate non-administrator account can exploit a vulnerability in the user ID creation mechanism in Apache StreamPipes that allows them to swap the username of an existing user with that of an administrator. 

This vulnerability allows an attacker to gain administrative control over the application by manipulating JWT tokens, which can lead to data tampering, unauthorized access and other security issues.

This issue affects Apache StreamPipes: through 0.97.0.

Users are recommended to upgrade to version 0.98.0, which fixes the issue.

Weakness: CWE-269

Which versions are affected by CVE-2025-47411?

2 open source packages ship an affected version, including org.apache.streampipes:streampipes-parent. It affects 1 product.

PackageAffectedFixed in
org.apache.streampipes:streampipes-parent MavenFrom 0.69.00.98.0
org.apache.streampipes:streampipes-parent MavenFrom 0.69.00.98.0

Products include Apache Streampipes.

How do I fix CVE-2025-47411?

Upgrade org.apache.streampipes:streampipes-parent to 0.98.0 or later.

Is CVE-2025-47411 being exploited?

There is no known exploitation of CVE-2025-47411 in the wild and no public exploit code.

Sources

Also known as GHSA-5r2g-vphf-m5xc.

Is CVE-2025-47411 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free