# CVE-2025-47411: Apache StreamPipes: Leverage of User ID for Privilege Escalation


- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 1 Jan 2026
- **Updated:** 5 Jan 2026
- **Also known as:** GHSA-5r2g-vphf-m5xc

## What is CVE-2025-47411?

CVE-2025-47411 is a high-severity vulnerability in Apache StreamPipes, published on 1 Jan 2026. 

### Official description

A user with a legitimate non-administrator account can exploit a vulnerability in the user ID creation mechanism in Apache StreamPipes that allows them to swap the username of an existing user with that of an administrator. 

This vulnerability allows an attacker to gain administrative control over the application by manipulating JWT tokens, which can lead to data tampering, unauthorized access and other security issues.

This issue affects Apache StreamPipes: through 0.97.0.

Users are recommended to upgrade to version 0.98.0, which fixes the issue.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2025-47411?

2 open source packages ship an affected version, including org.apache.streampipes:streampipes-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.streampipes:streampipes-parent` | Maven | From 0.69.0 | 0.98.0 |
| `org.apache.streampipes:streampipes-parent` | Maven | From 0.69.0 | 0.98.0 |

Products: Apache Streampipes.

## How do I fix CVE-2025-47411?

Upgrade org.apache.streampipes:streampipes-parent to 0.98.0 or later.

## Is CVE-2025-47411 being exploited?

There is no known exploitation of CVE-2025-47411 in the wild and no public exploit code.

## Other vulnerabilities in Apache StreamPipes

- [CVE-2024-29868](https://insights.sbomify.com/CVE-2024-29868/): Apache StreamPipes: Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) in Recovery Token Generation (critical 9.1)
- [CVE-2023-31469](https://insights.sbomify.com/CVE-2023-31469/): Apache StreamPipes: Privilege escalation through non-admin user (high 8.8)
- [CVE-2024-31979](https://insights.sbomify.com/CVE-2024-31979/): Apache StreamPipes: Possibility of SSRF in pipeline element installation process (high 7.5)
- [CVE-2024-24778](https://insights.sbomify.com/CVE-2024-24778/): Apache StreamPipes: Resources Permission Escalation (medium 6.5)
- [CVE-2024-31411](https://insights.sbomify.com/CVE-2024-31411/): Apache StreamPipes: Potential remote code execution (RCE) via file upload (medium 6.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47411 and fix it if it is affected.

What it is: CVE-2025-47411 is a high-severity vulnerability in Apache StreamPipes, published on 1 Jan 2026. 
Exploitation: There is no known exploitation of CVE-2025-47411 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.streampipes:streampipes-parent (Maven): affected from 0.69.0; fixed in 0.98.0
- org.apache.streampipes:streampipes-parent (Maven): affected from 0.69.0; fixed in 0.98.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47411/ (Markdown: https://insights.sbomify.com/CVE-2025-47411/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47411
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47411
- OSV: https://osv.dev/vulnerability/CVE-2025-47411

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47411/
Summaries are generated and may contain mistakes; the official description above is the record.
