{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-47436 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-47436 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-47436 is a medium-severity memory corruption vulnerability in Apache ORC, published on 14 May 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-47436 and fix it if it is affected.\n\nWhat it is: CVE-2025-47436 is a medium-severity memory corruption vulnerability in Apache ORC, published on 14 May 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-47436 in the wild and no public exploit code.\n\nAffected product: Apache ORC. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-47436/ (Markdown: https://insights.sbomify.com/CVE-2025-47436/index.md)","id":"CVE-2025-47436","markdown":"https://insights.sbomify.com/CVE-2025-47436/index.md","name":"CVE-2025-47436","record":{"aliases":["AZL-61829","AZL-61836","GHSA-h527-m3cp-9hm7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Apache ORC C++ library","requires_auth":"high_privilege","summary":"Heap buffer overflow in Apache ORC C++ LZO decompression allows attackers to cause memory corruption via crafted files, potentially leading to code execution or crashes.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"orc","vendor":"apache"}],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:A/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H/S:N/RE:M/U:Amber","version":"4.0"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"Heap-based Buffer Overflow vulnerability in Apache ORC.\n\nA vulnerability has been identified in the ORC C++ LZO decompression logic, where specially crafted malformed ORC files can cause the decompressor to allocate a 250-byte buffer but then attempts to copy 295 bytes into it. It causes memory corruption.\n\nThis issue affects Apache ORC C++ library: through 1.8.8, from 1.9.0 through 1.9.5, from 2.0.0 through 2.0.4, from 2.1.0 through 2.1.1.\n\nUsers are recommended to upgrade to version 1.8.9, 1.9.6, 2.0.5, and 2.1.2, which fix the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Apache ORC: Potential Heap Buffer Overflow during C++ LZO Decompression","id":"CVE-2025-47436","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"WordPress LiteSpeed Cache plugin \u003c= 7.0.1 - Server Side Request Forgery (SSRF) vulnerability","id":"CVE-2025-47437"},"packages":[],"prev":{"headline":"Other in Retool","id":"CVE-2025-47424"},"products":["Apache ORC"],"published":"2025-05-14","related":[{"cvss_score":7.5,"headline":"Apache ORC vulnerable to Uncontrolled Recursion","id":"CVE-2018-8015","kev_date_added":null,"published":"2018-05-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-14","vendors":["Apache Software Foundation"]},"summary":"Heap buffer overflow in Apache ORC C++ LZO decompression allows attackers to cause memory corruption via crafted files, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2025-47436/"}