{"answers":{"affected":"2 open source packages ship an affected version, including lockfile-lint-api. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-4759 exists.","fix":"Upgrade lockfile-lint-api to 5.9.2 or later.","what":"CVE-2025-4759 is a medium-severity vulnerability in lockfile-lint-api, published on 16 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-4759 and fix it if it is affected.\n\nWhat it is: CVE-2025-4759 is a medium-severity vulnerability in lockfile-lint-api, published on 16 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-4759 exists.\n\nAffected packages and fixed versions:\n- lockfile-lint-api (npm): affected all versions; fixed in 5.9.2\n- lockfile-lint-api (npm): affected all versions; fixed in 5.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-4759/ (Markdown: https://insights.sbomify.com/CVE-2025-4759/index.md)","id":"CVE-2025-4759","markdown":"https://insights.sbomify.com/CVE-2025-4759/index.md","name":"CVE-2025-4759","record":{"aliases":["GHSA-7cfr-5cjf-32p4"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"npm lockfile linting tool","requires_auth":"none","summary":"Attackers can bypass package validation to install unintended npm packages, potentially leading to code execution.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"lockfile-lint-api","vendor":"lirantal"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:L/E:P","version":"4.0"},"cwes":[{"id":"CWE-179","name":"Incorrect Behavior Order: Early Validation"}],"description":"Versions of the package lockfile-lint-api before 5.9.2 are vulnerable to Incorrect Behavior Order: Early Validation via the resolved attribute of the package URL validation which can be bypassed by extending the package name allowing an attacker to install other npm packages than the intended one.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"lockfile-lint-api Vulnerable to Incorrect Behavior Order","id":"CVE-2025-4759","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"business_logic","year":"2025"},"n_packages":2,"n_references":5,"next":{"headline":"Authenticated Stored Cross-Site Scripting (XSS) in Multiple WSO2 Products via API Document Upload in Publisher","id":"CVE-2025-4760"},"packages":[{"ecosystem":"npm","fixed":["5.9.2"],"introduced":["0"],"last_affected":[],"package":"lockfile-lint-api","purl":null,"source":"GHSA-7cfr-5cjf-32p4"},{"ecosystem":"npm","fixed":["5.9.2"],"introduced":["0"],"last_affected":[],"package":"lockfile-lint-api","purl":"pkg:npm/lockfile-lint-api","source":"GHSA-7cfr-5cjf-32p4"}],"prev":{"headline":"PHPGurukul Beauty Parlour Management System contact.php sql injection","id":"CVE-2025-4758"},"products":["lockfile-lint-api"],"published":"2025-05-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-16","vendors":["n/a"]},"summary":"Attackers can bypass package validation to install unintended npm packages, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2025-4759/"}