# CVE-2025-4759: lockfile-lint-api Vulnerable to Incorrect Behavior Order

> Attackers can bypass package validation to install unintended npm packages, potentially leading to code execution.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 May 2025
- **Updated:** 16 May 2025
- **Also known as:** GHSA-7cfr-5cjf-32p4

## What is CVE-2025-4759?

CVE-2025-4759 is a medium-severity vulnerability in lockfile-lint-api, published on 16 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package lockfile-lint-api before 5.9.2 are vulnerable to Incorrect Behavior Order: Early Validation via the resolved attribute of the package URL validation which can be bypassed by extending the package name allowing an attacker to install other npm packages than the intended one.

Weakness: CWE-179 (Incorrect Behavior Order: Early Validation)

## Which versions are affected by CVE-2025-4759?

2 open source packages ship an affected version, including lockfile-lint-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lockfile-lint-api` | npm | All versions | 5.9.2 |
| `lockfile-lint-api` | npm | All versions | 5.9.2 |

Products: Lirantal Lockfile-Lint-Api.

## How do I fix CVE-2025-4759?

Upgrade lockfile-lint-api to 5.9.2 or later.

## Is CVE-2025-4759 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-4759 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4759 and fix it if it is affected.

What it is: CVE-2025-4759 is a medium-severity vulnerability in lockfile-lint-api, published on 16 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-4759 exists.

Affected packages and fixed versions:
- lockfile-lint-api (npm): affected all versions; fixed in 5.9.2
- lockfile-lint-api (npm): affected all versions; fixed in 5.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4759/ (Markdown: https://insights.sbomify.com/CVE-2025-4759/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4759
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4759
- OSV: https://osv.dev/vulnerability/CVE-2025-4759

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4759/
Summaries are generated and may contain mistakes; the official description above is the record.
