# CVE-2025-4760: Authenticated Stored Cross-Site Scripting (XSS) in Multiple WSO2 Products via API Document Upload in Publisher

> Authenticated users can inject malicious scripts via API document uploads, leading to data exfiltration or UI manipulation in WSO2 products.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Sep 2025
- **Updated:** 23 Sep 2025
- **Also known as:** GHSA-cmjc-qp7j-xgwr

## What is CVE-2025-4760?

CVE-2025-4760 is a medium-severity cross-site scripting vulnerability in Wso2 Api Manager, published on 23 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

An authenticated stored cross-site scripting (XSS) vulnerability exists in multiple WSO2 products due to improper validation of user-supplied input during API document upload in the Publisher portal. A user with publisher privileges can upload a crafted API document containing malicious JavaScript, which is later rendered in the browser when accessed by other users.

A successful attack could result in redirection to malicious websites, unauthorized UI modifications, or exfiltration of browser-accessible data. However, session-related sensitive cookies are protected by the httpOnly flag, preventing session hijacking.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-4760?

4 open source packages ship an affected version, including org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.api and org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.rest.api.publisher.v1. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.api` | Maven | All versions | 9.31.117 |
| `org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.api` | Maven | All versions | 9.31.117 |
| `org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.rest.api.publisher.v1` | Maven | All versions | 9.31.117 |
| `org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.rest.api.publisher.v1` | Maven | All versions | 9.31.117 |

Products: Wso2 Api Control Plane, Wso2 Api Manager, Wso2 Traffic Manager, Wso2 Universal Gateway.

## How do I fix CVE-2025-4760?

Upgrade org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.api to 9.31.117 or later.

## Is CVE-2025-4760 being exploited?

There is no known exploitation of CVE-2025-4760 in the wild and no public exploit code.

## Other vulnerabilities in Wso2 Api Manager

- [CVE-2026-5430](https://insights.sbomify.com/CVE-2026-5430/): WSO2 Multiple Products Path Traversal Vulnerability (critical 10.0, exploited in the wild)
- [CVE-2026-1728](https://insights.sbomify.com/CVE-2026-1728/): Privilege Escalation via System REST APIs in Multiple WSO2 Products Permits Admin Account Takeover (critical 9.8)
- [CVE-2025-9312](https://insights.sbomify.com/CVE-2025-9312/): Improper Certificate-Based Authentication Enforcement in Multiple WSO2 Products (critical 9.8)
- [CVE-2025-10611](https://insights.sbomify.com/CVE-2025-10611/): Potential Broken Access Control in Multiple WSO2 Products via System REST APIs (critical 9.8)
- [CVE-2025-9152](https://insights.sbomify.com/CVE-2025-9152/): Improper Privilege Management in Multiple WSO2 API Manager via keymanager-operations DCR Endpoint (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4760 and fix it if it is affected.

What it is: CVE-2025-4760 is a medium-severity cross-site scripting vulnerability in Wso2 Api Manager, published on 23 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-4760 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.api (Maven): affected all versions; fixed in 9.31.117
- org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.api (Maven): affected all versions; fixed in 9.31.117
- org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.rest.api.publisher.v1 (Maven): affected all versions; fixed in 9.31.117
- org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.rest.api.publisher.v1 (Maven): affected all versions; fixed in 9.31.117

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4760/ (Markdown: https://insights.sbomify.com/CVE-2025-4760/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4760
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4760
- OSV: https://osv.dev/vulnerability/CVE-2025-4760

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4760/
Summaries are generated and may contain mistakes; the official description above is the record.
