CVE-2025-47700 AI plugin APIs can be triggered using post actions
Attackers can trigger AI plugin APIs via malicious links due to missing validation of empty request bodies in the Agents plugin.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-47700?
CVE-2025-47700 is a low-severity server-side request forgery vulnerability in Mattermost Mattermost Server, published on 21 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Mattermost Server versions 10.5.x <= 10.5.9 utilizing the Agents plugin fail to reject empty request bodies which allows users to trick users into clicking malicious links via post actions
Weakness: CWE-918
Which versions are affected by CVE-2025-47700?
8 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.10 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.10 |
github.com/mattermost/mattermost-server Go | From 10.5.0+incompatible | 10.5.10+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250814075248-83a37a861d3c |
2 more packages
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250814075248-83a37a861d3c |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250814075248-83a37a861d3c |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-47700?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.10 or 10.5.10+incompatible.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2025-47700 being exploited?
There is no known exploitation of CVE-2025-47700 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-vqwh-5jhh-vc9p, GO-2025-3906.