# CVE-2025-47700: AI plugin APIs can be triggered using post actions

> Attackers can trigger AI plugin APIs via malicious links due to missing validation of empty request bodies in the Agents plugin.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Aug 2025
- **Updated:** 21 Aug 2025
- **Also known as:** GHSA-vqwh-5jhh-vc9p, GO-2025-3906

## What is CVE-2025-47700?

CVE-2025-47700 is a low-severity server-side request forgery vulnerability in Mattermost Mattermost Server, published on 21 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Mattermost Server versions 10.5.x <= 10.5.9 utilizing the Agents plugin fail to reject empty request bodies which allows users to trick users into clicking malicious links via post actions

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-47700?

8 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.10 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.10 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0+incompatible | 10.5.10+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250814075248-83a37a861d3c |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250814075248-83a37a861d3c |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250814075248-83a37a861d3c |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-47700?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.10 or 10.5.10+incompatible.

## Is CVE-2025-47700 being exploited?

There is no known exploitation of CVE-2025-47700 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47700 and fix it if it is affected.

What it is: CVE-2025-47700 is a low-severity server-side request forgery vulnerability in Mattermost Mattermost Server, published on 21 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-47700 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.10
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.10
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0+incompatible; fixed in 10.5.10+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250814075248-83a37a861d3c
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250814075248-83a37a861d3c
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250814075248-83a37a861d3c

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47700/ (Markdown: https://insights.sbomify.com/CVE-2025-47700/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47700
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47700
- OSV: https://osv.dev/vulnerability/CVE-2025-47700

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47700/
Summaries are generated and may contain mistakes; the official description above is the record.
