CVE-2025-47713 Apache CloudStack: Domain Admin can reset Admin password in Root Domain

High 8.8 Published Updated

A Domain Admin in the root domain can reset Admin passwords, allowing privilege escalation and account takeover in Apache CloudStack.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-47713?

CVE-2025-47713 is a high-severity vulnerability in Apache Cloudstack, published on 10 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A privilege escalation vulnerability exists in Apache CloudStack versions 4.10.0.0 through 4.20.0.0 where a malicious Domain Admin user in the ROOT domain can reset the password of user-accounts of Admin role type. This operation is not appropriately restricted and allows the attacker to assume control over higher-privileged user-accounts. A malicious Domain Admin attacker can impersonate an Admin user-account and gain access to sensitive APIs and resources that could result in the compromise of resource integrity and confidentiality, data loss, denial of service, and availability of infrastructure managed by CloudStack.

Users are recommended to upgrade to Apache CloudStack 4.19.3.0 or 4.20.1.0, which fixes the issue with the following: * Strict validation on Role Type hierarchy: the caller's user-account role must be equal to or higher than the target user-account's role. * API privilege comparison: the caller must possess all privileges of the user they are operating on. * Two new domain-level settings (restricted to the default Admin):  - role.types.allowed.for.operations.on.accounts.of.same.role.type: Defines which role types are allowed to act on users of the same role type. Default: "Admin, DomainAdmin, ResourceAdmin".    - allow.operations.on.users.in.same.account: Allows/disallows user operations within the same account. Default: true.

Weakness: CWE-269

Which versions are affected by CVE-2025-47713?

It affects 1 product.

Products include Apache Cloudstack.

How do I fix CVE-2025-47713?

No fix has been published for CVE-2025-47713 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-47713 being exploited?

There is no known exploitation of CVE-2025-47713 in the wild and no public exploit code.

All Apache Cloudstack vulnerabilities

Sources

Also known as GHSA-qmmh-h9p5-p2f7.

Is CVE-2025-47713 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free