# CVE-2025-47713: Apache CloudStack: Domain Admin can reset Admin password in Root Domain

> A Domain Admin in the root domain can reset Admin passwords, allowing privilege escalation and account takeover in Apache CloudStack.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jun 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-qmmh-h9p5-p2f7

## What is CVE-2025-47713?

CVE-2025-47713 is a high-severity vulnerability in Apache Cloudstack, published on 10 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A privilege escalation vulnerability exists in Apache CloudStack versions 4.10.0.0 through 4.20.0.0 where a malicious Domain Admin user in the ROOT domain can reset the password of user-accounts of Admin role type. This operation is not appropriately restricted and allows the attacker to assume control over higher-privileged user-accounts. A malicious Domain Admin attacker can impersonate an Admin user-account and gain access to sensitive APIs and resources that could result in the compromise of resource integrity and confidentiality, data loss, denial of service, and availability of infrastructure managed by CloudStack.

Users are recommended to upgrade to Apache CloudStack 4.19.3.0 or 4.20.1.0, which fixes the issue with the following:
  *  Strict validation on Role Type hierarchy: the caller's user-account role must be equal to or higher than the target user-account's role.
  *  API privilege comparison: the caller must possess all privileges of the user they are operating on. 
  *  Two new domain-level settings (restricted to the default Admin): 
 - role.types.allowed.for.operations.on.accounts.of.same.role.type: Defines which role types are allowed to act on users of the same role type. Default: "Admin, DomainAdmin, ResourceAdmin". 
   - allow.operations.on.users.in.same.account: Allows/disallows user operations within the same account. Default: true.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2025-47713?

It affects 1 product.


Products: Apache Cloudstack.

## How do I fix CVE-2025-47713?

No fix has been published for CVE-2025-47713 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-47713 being exploited?

There is no known exploitation of CVE-2025-47713 in the wild and no public exploit code.

## Other vulnerabilities in Apache Cloudstack

- [CVE-2012-4501](https://insights.sbomify.com/CVE-2012-4501/): Missing authorization in n/a (critical 10.0)
- [CVE-2024-38346](https://insights.sbomify.com/CVE-2024-38346/): Apache CloudStack: Unauthenticated cluster service port leads to remote execution (critical 9.8)
- [CVE-2024-39864](https://insights.sbomify.com/CVE-2024-39864/): Apache CloudStack: Integration API service uses dynamic port when disabled (critical 9.8)
- [CVE-2024-29006](https://insights.sbomify.com/CVE-2024-29006/): Apache CloudStack: x-forwarded-for HTTP header parsed by default (critical 9.8)
- [CVE-2022-35741](https://insights.sbomify.com/CVE-2022-35741/): Apache CloudStack SAML Single Sign-On XXE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47713 and fix it if it is affected.

What it is: CVE-2025-47713 is a high-severity vulnerability in Apache Cloudstack, published on 10 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47713 in the wild and no public exploit code.

Affected product: Apache Cloudstack. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47713/ (Markdown: https://insights.sbomify.com/CVE-2025-47713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47713
- OSV: https://osv.dev/vulnerability/CVE-2025-47713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47713/
Summaries are generated and may contain mistakes; the official description above is the record.
