CVE-2025-47771 PowSyBl Core allows deserialization of untrusted SparseMatrix data
Attackers can achieve privilege escalation or code execution by exploiting unsafe deserialization in the PowSyBl Core library's SparseMatrix class.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-47771?
CVE-2025-47771 is a high-severity unsafe deserialization vulnerability in powsybl-core, published on 19 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
PowSyBl (Power System Blocks) is a framework to build power system oriented software. In versions 6.3.0 to 6.7.1, there is a deserialization issue in the read method of the SparseMatrix class that can lead to a wide range of privilege escalations depending on the circumstances. This method takes in an InputStream and returns a SparseMatrix object. This issue has been patched in com.powsybl:powsybl-math: 6.7.2. A workaround for this issue involves not using SparseMatrix deserialization (SparseMatrix.read(...) methods).
Weakness: CWE-502
Which versions are affected by CVE-2025-47771?
2 open source packages ship an affected version, including com.powsybl:powsybl-math.
| Package | Affected | Fixed in |
|---|---|---|
com.powsybl:powsybl-math Maven | From 6.3.0 | 6.7.2 |
com.powsybl:powsybl-math Maven | From 6.3.0 | 6.7.2 |
How do I fix CVE-2025-47771?
Upgrade com.powsybl:powsybl-math to 6.7.2 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2025-47771 being exploited?
There is no known exploitation of CVE-2025-47771 in the wild and no public exploit code.
Sources
Also known as GHSA-f5cx-h789-j959.