{"answers":{"affected":"2 open source packages ship an affected version, including com.powsybl:powsybl-math.","exploited":"There is no known exploitation of CVE-2025-47771 in the wild and no public exploit code.","fix":"Upgrade com.powsybl:powsybl-math to 6.7.2 or later.","what":"CVE-2025-47771 is a high-severity unsafe deserialization vulnerability in powsybl-core, published on 19 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-47771 and fix it if it is affected.\n\nWhat it is: CVE-2025-47771 is a high-severity unsafe deserialization vulnerability in powsybl-core, published on 19 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-47771 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.powsybl:powsybl-math (Maven): affected from 6.3.0; fixed in 6.7.2\n- com.powsybl:powsybl-math (Maven): affected from 6.3.0; fixed in 6.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-47771/ (Markdown: https://insights.sbomify.com/CVE-2025-47771/index.md)","id":"CVE-2025-47771","markdown":"https://insights.sbomify.com/CVE-2025-47771/index.md","name":"CVE-2025-47771","record":{"aliases":["GHSA-f5cx-h789-j959"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java power system library","requires_auth":"none","summary":"Attackers can achieve privilege escalation or code execution by exploiting unsafe deserialization in the PowSyBl Core library's SparseMatrix class.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"PowSyBl (Power System Blocks) is a framework to build power system oriented software. In versions 6.3.0 to 6.7.1, there is a deserialization issue in the read method of the SparseMatrix class that can lead to a wide range of privilege escalations depending on the circumstances. This method takes in an InputStream and returns a SparseMatrix object. This issue has been patched in com.powsybl:powsybl-math: 6.7.2. A workaround for this issue involves not using SparseMatrix deserialization (SparseMatrix.read(...) methods).","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PowSyBl Core allows deserialization of untrusted SparseMatrix data","id":"CVE-2025-47771","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Combodo iTop has XSS vulnerability in /pages/ajax.render.php","id":"CVE-2025-47773"},"packages":[{"ecosystem":"Maven","fixed":["6.7.2"],"introduced":["6.3.0"],"last_affected":[],"package":"com.powsybl:powsybl-math","purl":null,"source":"GHSA-f5cx-h789-j959"},{"ecosystem":"Maven","fixed":["6.7.2"],"introduced":["6.3.0"],"last_affected":[],"package":"com.powsybl:powsybl-math","purl":"pkg:maven/com.powsybl/powsybl-math","source":"GHSA-f5cx-h789-j959"}],"prev":{"headline":"Not used","id":"CVE-2025-47770"},"products":["powsybl-core"],"published":"2025-06-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-20","vendors":["powsybl"]},"summary":"Attackers can achieve privilege escalation or code execution by exploiting unsafe deserialization in the PowSyBl Core library's SparseMatrix class.","url":"https://insights.sbomify.com/CVE-2025-47771/"}