# CVE-2025-47771: PowSyBl Core allows deserialization of untrusted SparseMatrix data

> Attackers can achieve privilege escalation or code execution by exploiting unsafe deserialization in the PowSyBl Core library's SparseMatrix class.

- **Severity:** High 8.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2025
- **Updated:** 20 Jun 2025
- **Also known as:** GHSA-f5cx-h789-j959

## What is CVE-2025-47771?

CVE-2025-47771 is a high-severity unsafe deserialization vulnerability in powsybl-core, published on 19 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PowSyBl (Power System Blocks) is a framework to build power system oriented software. In versions 6.3.0 to 6.7.1, there is a deserialization issue in the read method of the SparseMatrix class that can lead to a wide range of privilege escalations depending on the circumstances. This method takes in an InputStream and returns a SparseMatrix object. This issue has been patched in com.powsybl:powsybl-math: 6.7.2. A workaround for this issue involves not using SparseMatrix deserialization (SparseMatrix.read(...) methods).

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-47771?

2 open source packages ship an affected version, including com.powsybl:powsybl-math.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.powsybl:powsybl-math` | Maven | From 6.3.0 | 6.7.2 |
| `com.powsybl:powsybl-math` | Maven | From 6.3.0 | 6.7.2 |

## How do I fix CVE-2025-47771?

Upgrade com.powsybl:powsybl-math to 6.7.2 or later.

## Is CVE-2025-47771 being exploited?

There is no known exploitation of CVE-2025-47771 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47771 and fix it if it is affected.

What it is: CVE-2025-47771 is a high-severity unsafe deserialization vulnerability in powsybl-core, published on 19 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47771 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.powsybl:powsybl-math (Maven): affected from 6.3.0; fixed in 6.7.2
- com.powsybl:powsybl-math (Maven): affected from 6.3.0; fixed in 6.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47771/ (Markdown: https://insights.sbomify.com/CVE-2025-47771/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47771
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47771
- OSV: https://osv.dev/vulnerability/CVE-2025-47771

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47771/
Summaries are generated and may contain mistakes; the official description above is the record.
