# CVE-2025-47775: Bullfrog's DNS over TCP bypasses domain filtering

> Attackers can bypass DNS filtering in Bullfrog GitHub Actions by using TCP, enabling data exfiltration and sandbox escape.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2025
- **Updated:** 14 May 2025
- **Also known as:** GHSA-m32f-fjw2-37v3

## What is CVE-2025-47775?

CVE-2025-47775 is a medium-severity vulnerability in bullfrogsec bullfrog, published on 14 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Bullfrog is a GithHb Action to block unauthorized outbound traffic in GitHub workflows. Prior to version 0.8.4, using tcp breaks blocking and allows DNS exfiltration. This can result in sandbox bypass. Version 0.8.4 fixes the issue.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2025-47775?

1 open source package ship an affected version, including bullfrogsec/bullfrog. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bullfrogsec/bullfrog` | GitHub Actions | All versions | 0.8.4 |

Products: Bullfrogsec Bullfrog.

## How do I fix CVE-2025-47775?

Upgrade bullfrogsec/bullfrog to 0.8.4 or later.

## Is CVE-2025-47775 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47775 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47775 and fix it if it is affected.

What it is: CVE-2025-47775 is a medium-severity vulnerability in bullfrogsec bullfrog, published on 14 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47775 exists.

Affected packages and fixed versions:
- bullfrogsec/bullfrog (GitHub Actions): affected all versions; fixed in 0.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47775/ (Markdown: https://insights.sbomify.com/CVE-2025-47775/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47775
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47775
- OSV: https://osv.dev/vulnerability/CVE-2025-47775

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47775/
Summaries are generated and may contain mistakes; the official description above is the record.
