# CVE-2025-47782: motionEye vulnerable to RCE in add_camera Function Due to unsafe command execution

> An authenticated admin can execute arbitrary commands via the add_camera API due to unsafe command execution in motionEye.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2025
- **Updated:** 14 May 2025
- **Also known as:** GHSA-g5mq-prx7-c588, PYSEC-2025-39

## What is CVE-2025-47782?

CVE-2025-47782 is a high-severity command injection vulnerability in motioneye-project motioneye, published on 14 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

motionEye is an online interface for the software motion, a video surveillance program with motion detection. In versions 0.43.1b1 through 0.43.1b3, using a constructed (camera) device path with the `add`/`add_camera` motionEye web API allows an attacker with motionEye admin user credentials to execute any command within a non-interactive shell as motionEye run user, `motion` by default. The vulnerability has been patched with motionEye v0.43.1b4. As a workaround, apply the patch manually.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-47782?

3 open source packages ship an affected version, including motioneye.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `motioneye` | PyPI | From 0.43.1b1 | 0.43.1b4 |
| `motioneye` | PyPI | From 0.43.1b1 | 0.43.1b4 |
| `motioneye` | PyPI | From 0.43.1b1 | 0.43.1b4 |

## How do I fix CVE-2025-47782?

Upgrade motioneye to 0.43.1b4 or later.

## Is CVE-2025-47782 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47782 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47782 and fix it if it is affected.

What it is: CVE-2025-47782 is a high-severity command injection vulnerability in motioneye-project motioneye, published on 14 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47782 exists.

Affected packages and fixed versions:
- motioneye (PyPI): affected from 0.43.1b1; fixed in 0.43.1b4
- motioneye (PyPI): affected from 0.43.1b1; fixed in 0.43.1b4
- motioneye (PyPI): affected from 0.43.1b1; fixed in 0.43.1b4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47782/ (Markdown: https://insights.sbomify.com/CVE-2025-47782/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47782
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47782
- OSV: https://osv.dev/vulnerability/CVE-2025-47782

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47782/
Summaries are generated and may contain mistakes; the official description above is the record.
