# CVE-2025-47783: label-studio vulnerable to Cross-Site Scripting (Reflected) via the label_config parameter.

> Attackers can inject malicious scripts via the label_config parameter in Label Studio, leading to data theft and session hijacking.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2025
- **Updated:** 15 May 2025
- **Also known as:** GHSA-8jhr-wpcm-hh4h, PYSEC-2025-124

## What is CVE-2025-47783?

CVE-2025-47783 is a high-severity cross-site scripting vulnerability in HumanSignal label-studio, published on 14 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Label Studio is a multi-type data labeling and annotation tool. A vulnerability in versions prior to 1.18.0 allows an attacker to inject a malicious script into the context of a web page, which can lead to data theft, session hijacking, unauthorized actions on behalf of the user, and other attacks. The vulnerability is reproducible when sending a properly formatted request to the `POST /projects/upload-example/` endpoint. In the source code, the vulnerability is located at `label_studio/projects/views.py`. Version 1.18.0 contains a patch for the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-47783?

3 open source packages ship an affected version, including label-studio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `label-studio` | PyPI | All versions | 1.18.0 |
| `label-studio` | PyPI | All versions | 1.18.0 |
| `label-studio` | PyPI | All versions | 1.18.0 |

Products: Humansignal Label Studio.

## How do I fix CVE-2025-47783?

Upgrade label-studio to 1.18.0 or later.

## Is CVE-2025-47783 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47783 exists.

Public exploit code:

- Label Studio < 1.18.0 - Reflected XSS (nuclei): http/cves/2025/CVE-2025-47783.yaml

## Other vulnerabilities in HumanSignal label-studio

- [CVE-2023-43791](https://insights.sbomify.com/CVE-2023-43791/): Label Studio has Hardcoded Django `SECRET_KEY` that can be Abused to Forge Session Tokens (critical 9.8)
- [CVE-2026-22033](https://insights.sbomify.com/CVE-2026-22033/): Label Studio vulnerable to full account takeover by chaining Stored XSS + IDOR in User Profile via custom_hotkeys field (high 8.6)
- [CVE-2025-25297](https://insights.sbomify.com/CVE-2025-25297/): Label Studio allows Server-Side Request Forgery in the S3 Storage Endpoint (high 8.6)
- [CVE-2023-47117](https://insights.sbomify.com/CVE-2023-47117/): Object Relational Mapper Leak Vulnerability in Filtering Task in Label Studio (high 7.5)
- [CVE-2023-47115](https://insights.sbomify.com/CVE-2023-47115/): Label Studio XSS Vulnerability on Avatar Upload (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47783 and fix it if it is affected.

What it is: CVE-2025-47783 is a high-severity cross-site scripting vulnerability in HumanSignal label-studio, published on 14 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47783 exists.

Affected packages and fixed versions:
- label-studio (PyPI): affected all versions; fixed in 1.18.0
- label-studio (PyPI): affected all versions; fixed in 1.18.0
- label-studio (PyPI): affected all versions; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47783/ (Markdown: https://insights.sbomify.com/CVE-2025-47783/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47783
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47783
- OSV: https://osv.dev/vulnerability/CVE-2025-47783

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47783/
Summaries are generated and may contain mistakes; the official description above is the record.
