{"answers":{"affected":"2 open source packages ship an affected version, including @lumieducation/h5p-server.","exploited":"There is no known exploitation of CVE-2025-47828 in the wild and no public exploit code.","fix":"Upgrade @lumieducation/h5p-server to 9.3.3 or later.","what":"CVE-2025-47828 is a medium-severity cross-site scripting vulnerability in Lumi H5P-Nodejs-library, published on 11 May 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-47828 and fix it if it is affected.\n\nWhat it is: CVE-2025-47828 is a medium-severity cross-site scripting vulnerability in Lumi H5P-Nodejs-library, published on 11 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-47828 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @lumieducation/h5p-server (npm): affected all versions; fixed in 9.3.3\n- @lumieducation/h5p-server (npm): affected all versions; fixed in 9.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-47828/ (Markdown: https://insights.sbomify.com/CVE-2025-47828/index.md)","id":"CVE-2025-47828","markdown":"https://insights.sbomify.com/CVE-2025-47828/index.md","name":"CVE-2025-47828","record":{"aliases":["GHSA-m7gm-v253-56hh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"H5P Node.js library","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts via unsanitized plain text strings in the H5P Node.js library, potentially leading to code execution.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Lumi H5P-Nodejs-library before 9.3.3 omits a sanitizeHtml call for plain text strings.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"@lumieducation/h5p-server Fails to Sanitize Plain Text Strings","id":"CVE-2025-47828","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Apache CloudStack: Insecure access of user's API/Secret Keys in the same domain","id":"CVE-2025-47849"},"packages":[{"ecosystem":"npm","fixed":["9.3.3"],"introduced":["0"],"last_affected":[],"package":"@lumieducation/h5p-server","purl":null,"source":"GHSA-m7gm-v253-56hh"},{"ecosystem":"npm","fixed":["9.3.3"],"introduced":["0"],"last_affected":[],"package":"@lumieducation/h5p-server","purl":"pkg:npm/%40lumieducation/h5p-server","source":"GHSA-m7gm-v253-56hh"}],"prev":{"headline":"IGEL OS Use of a Key Past its Expiration Date","id":"CVE-2025-47827"},"products":["H5P-Nodejs-library"],"published":"2025-05-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-27","vendors":["Lumi"]},"summary":"An attacker can inject malicious scripts via unsanitized plain text strings in the H5P Node.js library, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2025-47828/"}