# CVE-2025-47828: @lumieducation/h5p-server Fails to Sanitize Plain Text Strings

> An attacker can inject malicious scripts via unsanitized plain text strings in the H5P Node.js library, potentially leading to code execution.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2025
- **Updated:** 27 Sep 2026
- **Also known as:** GHSA-m7gm-v253-56hh

## What is CVE-2025-47828?

CVE-2025-47828 is a medium-severity cross-site scripting vulnerability in Lumi H5P-Nodejs-library, published on 11 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Lumi H5P-Nodejs-library before 9.3.3 omits a sanitizeHtml call for plain text strings.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-47828?

2 open source packages ship an affected version, including @lumieducation/h5p-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@lumieducation/h5p-server` | npm | All versions | 9.3.3 |
| `@lumieducation/h5p-server` | npm | All versions | 9.3.3 |

## How do I fix CVE-2025-47828?

Upgrade @lumieducation/h5p-server to 9.3.3 or later.

## Is CVE-2025-47828 being exploited?

There is no known exploitation of CVE-2025-47828 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47828 and fix it if it is affected.

What it is: CVE-2025-47828 is a medium-severity cross-site scripting vulnerability in Lumi H5P-Nodejs-library, published on 11 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47828 in the wild and no public exploit code.

Affected packages and fixed versions:
- @lumieducation/h5p-server (npm): affected all versions; fixed in 9.3.3
- @lumieducation/h5p-server (npm): affected all versions; fixed in 9.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47828/ (Markdown: https://insights.sbomify.com/CVE-2025-47828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47828
- OSV: https://osv.dev/vulnerability/CVE-2025-47828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47828/
Summaries are generated and may contain mistakes; the official description above is the record.
