CVE-2025-47870 Team invite ID leaked to team admin with no member invite privileges
Team admins without invite privileges can retrieve the team invite ID due to insufficient sanitization in the restore endpoint.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-47870?
CVE-2025-47870 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 21 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.9.x <= 10.9.2 fail to sanitize the team invite ID in the POST /api/v4/teams/:teamId/restore endpoint which allows an team admin with no member invite privileges to get the team’s invite id.
Weakness: CWE-306
Which versions are affected by CVE-2025-47870?
18 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.9 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.9 |
github.com/mattermost/mattermost-server Go | From 10.8.0 | 10.8.4 |
github.com/mattermost/mattermost-server Go | From 10.8.0 | 10.8.4 |
github.com/mattermost/mattermost-server Go | From 10.9.0 | 10.9.3 |
github.com/mattermost/mattermost-server Go | From 10.9.0 | 10.9.3 |
12 more packages
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.18 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.18 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.18+incompatible, 10.5.9+incompatible, 10.8.4+incompatible, 10.9.3+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v5 Go | All versions to 5.39.3 | None |
github.com/mattermost/mattermost-server/v5 Go | All versions to 5.39.3 | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions to 6.7.2 | None |
github.com/mattermost/mattermost-server/v6 Go | All versions to 6.7.2 | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250708065844-b38e2eccda18 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250708065844-b38e2eccda18 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250708065844-b38e2eccda18 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-47870?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.9, 10.8.4, 10.9.3 or 9.11.18.
Is CVE-2025-47870 being exploited?
There is no known exploitation of CVE-2025-47870 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-qj47-w9f2-qg44, GO-2025-3905.