# CVE-2025-47885: Jenkins Health Advisor by CloudBees Plugin Vulnerable to Cross-Site Scripting

> Stored XSS in Jenkins Health Advisor plugin allows attackers controlling server responses to execute scripts in user sessions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2025
- **Updated:** 20 May 2025
- **Also known as:** GHSA-xrpq-4g9w-qrwj

## What is CVE-2025-47885?

CVE-2025-47885 is a high-severity cross-site scripting vulnerability in Jenkins Health Advisor by CloudBees Plugin, published on 14 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins Health Advisor by CloudBees Plugin 374.v194b_d4f0c8c8 and earlier does not escape responses from the Jenkins Health Advisor server, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control Jenkins Health Advisor server responses.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-47885?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:cloudbees-jenkins-advisor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:cloudbees-jenkins-advisor` | Maven | All versions | 374.376.v3a_41a_a_142efe |
| `org.jenkins-ci.plugins:cloudbees-jenkins-advisor` | Maven | All versions | 374.376.v3a_41a_a_142efe |

Products: Jenkins Health Advisor by Cloudbees.

## How do I fix CVE-2025-47885?

Upgrade org.jenkins-ci.plugins:cloudbees-jenkins-advisor to 374.376.v3a_41a_a_142efe or later.

## Is CVE-2025-47885 being exploited?

There is no known exploitation of CVE-2025-47885 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Health Advisor by CloudBees Plugin

- [CVE-2020-2093](https://insights.sbomify.com/CVE-2020-2093/): CSRF vulnerability in Health Advisor by CloudBees Plugin (high 8.8)
- [CVE-2020-2258](https://insights.sbomify.com/CVE-2020-2258/): Incorrect permission check in Health Advisor by CloudBees Plugin (medium 4.3)
- [CVE-2020-2094](https://insights.sbomify.com/CVE-2020-2094/): Missing permission checks in Health Advisor by CloudBees Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47885 and fix it if it is affected.

What it is: CVE-2025-47885 is a high-severity cross-site scripting vulnerability in Jenkins Health Advisor by CloudBees Plugin, published on 14 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-47885 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:cloudbees-jenkins-advisor (Maven): affected all versions; fixed in 374.376.v3a_41a_a_142efe
- org.jenkins-ci.plugins:cloudbees-jenkins-advisor (Maven): affected all versions; fixed in 374.376.v3a_41a_a_142efe

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47885/ (Markdown: https://insights.sbomify.com/CVE-2025-47885/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47885
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47885
- OSV: https://osv.dev/vulnerability/CVE-2025-47885

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47885/
Summaries are generated and may contain mistakes; the official description above is the record.
