# CVE-2025-47905: Other in Varnish Cache

> Attackers can cause HTTP request desynchronization in Varnish Cache by exploiting improper CRLF handling in chunked encoding.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2025
- **Updated:** 29 May 2025
- **Also known as:** ALPINE-CVE-2025-47905, ALSA-2025:8336, ALSA-2025:8337, ALSA-2025:8550, BIT-varnish-2025-47905, DEBIAN-CVE-2025-47905, DLA-4187-1, GHSA-cvpp-rmjx-5x2m, OESA-2025-1556, RHSA-2025:8294, RHSA-2025:8310, RHSA-2025:8336, RHSA-2025:8337, RHSA-2025:8339, RHSA-2025:8340, RHSA-2025:8349, RHSA-2025:8350, RHSA-2025:8351, RHSA-2025:8550, RLSA-2025:8336, RLSA-2025:8337, RLSA-2025:8550, UBUNTU-CVE-2025-47905

## What is CVE-2025-47905?

CVE-2025-47905 is a medium-severity vulnerability in varnish-software Varnish Cache, published on 13 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Varnish Cache before 7.6.3 and 7.7 before 7.7.1, and Varnish Enterprise before 6.0.13r14, allow client-side desync via HTTP/1 requests, because the product incorrectly permits CRLF to be skipped to delimit chunk boundaries.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2025-47905?

1 open source package ship an affected version, including varnish.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `varnish` | Bitnami | All versions | 6.6.2 |
| `varnish` | AlmaLinux:10 | All versions | 7.6.1-2.el10_0.1 |
| `varnish-devel` | AlmaLinux:10 | All versions | 7.6.1-2.el10_0.1 |
| `varnish-docs` | AlmaLinux:10 | All versions | 7.6.1-2.el10_0.1 |
| `varnish` | AlmaLinux:8 | All versions | 6.0.13-1.module_el8.10.0+4003+9759c3c1.1 |
| `varnish-devel` | AlmaLinux:8 | All versions | 6.0.13-1.module_el8.10.0+4003+9759c3c1.1 |
| `varnish-docs` | AlmaLinux:8 | All versions | 6.0.13-1.module_el8.10.0+4003+9759c3c1.1 |
| `varnish-modules` | AlmaLinux:8 | All versions | 0.15.0-6.module_el8.9.0+3826+307eaba4 |
| `varnish` | AlmaLinux:9 | All versions | 6.6.2-6.el9_6.1 |
| `varnish-devel` | AlmaLinux:9 | All versions | 6.6.2-6.el9_6.1 |
| `varnish-docs` | AlmaLinux:9 | All versions | 6.6.2-6.el9_6.1 |
| `varnish` | Red Hat:enterprise_linux:10.0 | All versions | 0:7.6.1-2.el10_0.1 |
| `varnish-devel` | Red Hat:enterprise_linux:10.0 | All versions | 0:7.6.1-2.el10_0.1 |
| `varnish-docs` | Red Hat:enterprise_linux:10.0 | All versions | 0:7.6.1-2.el10_0.1 |
| `varnish` | Red Hat:enterprise_linux:8::appstream | All versions | 0:6.0.13-1.module+el8.10.0+23111+831cc069.1 |
| `varnish-devel` | Red Hat:enterprise_linux:8::appstream | All versions | 0:6.0.13-1.module+el8.10.0+23111+831cc069.1 |
| `varnish-docs` | Red Hat:enterprise_linux:8::appstream | All versions | 0:6.0.13-1.module+el8.10.0+23111+831cc069.1 |
| `varnish-modules` | Red Hat:enterprise_linux:8::appstream | All versions | 0:0.15.0-6.module+el8.10.0+21682+bcdd3a30 |
| `varnish-modules-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:0.15.0-6.module+el8.10.0+21682+bcdd3a30 |
| `varnish-modules-debugsource` | Red Hat:enterprise_linux:8::appstream | All versions | 0:0.15.0-6.module+el8.10.0+21682+bcdd3a30 |
| `varnish` | Red Hat:enterprise_linux:9::appstream | All versions | 0:6.6.2-6.el9_6.1 |
| `varnish-docs` | Red Hat:enterprise_linux:9::appstream | All versions | 0:6.6.2-6.el9_6.1 |
| `varnish-devel` | Red Hat:enterprise_linux:9::crb | All versions | 0:6.6.2-6.el9_6.1 |
| `varnish` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.0.6-1.module+el8.2.0+23124+897a7786.1 |
| `varnish-devel` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.0.6-1.module+el8.2.0+23124+897a7786.1 |
| `varnish-docs` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:6.0.6-1.module+el8.2.0+23124+897a7786.1 |
| `varnish-modules` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:0.15.0-4.module+el8+2481+4078e9d2 |
| `varnish-modules-debuginfo` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:0.15.0-4.module+el8+2481+4078e9d2 |
| `varnish-modules-debugsource` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:0.15.0-4.module+el8+2481+4078e9d2 |
| `varnish` | Red Hat:rhel_aus:8.4::appstream | All versions | 0:6.0.6-2.module+el8.4.0+23123+54dbaab7.6 |
| `varnish-devel` | Red Hat:rhel_aus:8.4::appstream | All versions | 0:6.0.6-2.module+el8.4.0+23123+54dbaab7.6 |
| `varnish-docs` | Red Hat:rhel_aus:8.4::appstream | All versions | 0:6.0.6-2.module+el8.4.0+23123+54dbaab7.6 |
| `varnish-modules` | Red Hat:rhel_aus:8.4::appstream | All versions | 0:0.15.0-5.module+el8.3.0+6843+b3b42fcc |
| `varnish-modules-debuginfo` | Red Hat:rhel_aus:8.4::appstream | All versions | 0:0.15.0-5.module+el8.3.0+6843+b3b42fcc |
| `varnish-modules-debugsource` | Red Hat:rhel_aus:8.4::appstream | All versions | 0:0.15.0-5.module+el8.3.0+6843+b3b42fcc |
| `varnish` | Red Hat:rhel_aus:8.6::appstream | All versions | 0:6.0.8-2.module+el8.6.0+23122+0639db89.4 |
| `varnish-devel` | Red Hat:rhel_aus:8.6::appstream | All versions | 0:6.0.8-2.module+el8.6.0+23122+0639db89.4 |
| `varnish-docs` | Red Hat:rhel_aus:8.6::appstream | All versions | 0:6.0.8-2.module+el8.6.0+23122+0639db89.4 |
| `varnish-modules` | Red Hat:rhel_aus:8.6::appstream | All versions | 0:0.15.0-6.module+el8.5.0+11976+0b4af72d |
| `varnish-modules-debuginfo` | Red Hat:rhel_aus:8.6::appstream | All versions | 0:0.15.0-6.module+el8.5.0+11976+0b4af72d |

## How do I fix CVE-2025-47905?

Upgrade varnish to 6.6.2 or later.

## Is CVE-2025-47905 being exploited?

There is no known exploitation of CVE-2025-47905 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47905 and fix it if it is affected.

What it is: CVE-2025-47905 is a medium-severity vulnerability in varnish-software Varnish Cache, published on 13 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47905 in the wild and no public exploit code.

Affected packages and fixed versions:
- varnish (Bitnami): affected all versions; fixed in 6.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47905/ (Markdown: https://insights.sbomify.com/CVE-2025-47905/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47905
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47905
- OSV: https://osv.dev/vulnerability/CVE-2025-47905

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47905/
Summaries are generated and may contain mistakes; the official description above is the record.
