{"answers":{"affected":"3 open source packages ship an affected version, including github.com/rs/cors.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47908 exists.","fix":"Upgrade github.com/rs/cors to 1.11.0 or later.","what":"CVE-2025-47908 is a high-severity denial of service vulnerability in github.com/rs/cors, published on 6 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-47908 and fix it if it is affected.\n\nWhat it is: CVE-2025-47908 is a high-severity denial of service vulnerability in github.com/rs/cors, published on 6 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47908 exists.\n\nAffected packages and fixed versions:\n- github.com/rs/cors (Go): affected from 1.9.0; fixed in 1.11.0\n- github.com/rs/cors (Go): affected from 1.9.0; fixed in 1.11.0\n- github.com/rs/cors (Go): affected from 1.9.0; fixed in 1.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-47908/ (Markdown: https://insights.sbomify.com/CVE-2025-47908/index.md)","id":"CVE-2025-47908","markdown":"https://insights.sbomify.com/CVE-2025-47908/index.md","name":"CVE-2025-47908","record":{"aliases":["CLEANSTART-2026-JT82999","CLEANSTART-2026-LQ54716","GHSA-mh55-gqvf-xfwm","GO-2024-2883","SUSE-SU-2025:4481-1","UBUNTU-CVE-2025-47908"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go CORS middleware","requires_auth":"none","summary":"Attackers can cause denial of service by sending malicious preflight requests with excessive commas in headers, leading to excessive heap allocations in the Go CORS middleware.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Go","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"Middleware causes a prohibitive amount of heap allocations when processing malicious preflight requests that include a Access-Control-Request-Headers (ACRH) header whose value contains many commas. This behavior can be abused by attackers to produce undue load on the middleware/server as an attempt to cause a denial of service.","ecosystems":["Go","SUSE:Linux Enterprise Module for Package Hub 15 SP6","SUSE:Linux Enterprise Module for Package Hub 15 SP7","SUSE:Manager Client Tools 15","SUSE:Manager Proxy LTS 4.3","openSUSE:Leap 15.6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service via malicious preflight requests in github.com/rs/cors","id":"CVE-2025-47908","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":8,"n_references":3,"next":{"headline":"Improper validation of TrustedOrigins allows CSRF attacks in github.com/gorilla/csrf","id":"CVE-2025-47909"},"packages":[{"ecosystem":"Go","fixed":["1.11.0"],"introduced":["1.9.0"],"last_affected":[],"package":"github.com/rs/cors","purl":null,"source":"GHSA-mh55-gqvf-xfwm"},{"ecosystem":"Go","fixed":["1.11.0"],"introduced":["1.9.0"],"last_affected":[],"package":"github.com/rs/cors","purl":"pkg:golang/github.com/rs/cors","source":"GHSA-mh55-gqvf-xfwm"},{"ecosystem":"Go","fixed":["1.11.0"],"introduced":["1.9.0"],"last_affected":[],"package":"github.com/rs/cors","purl":"pkg:golang/github.com/rs/cors","source":"GO-2024-2883"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP6","fixed":["0.28.1-150100.4.28.2"],"introduced":["0"],"last_affected":[],"package":"golang-github-prometheus-alertmanager","purl":"pkg:rpm/suse/golang-github-prometheus-alertmanager\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP6","source":"SUSE-SU-2025:4481-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP7","fixed":["0.28.1-150100.4.28.2"],"introduced":["0"],"last_affected":[],"package":"golang-github-prometheus-alertmanager","purl":"pkg:rpm/suse/golang-github-prometheus-alertmanager\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP7","source":"SUSE-SU-2025:4481-1"},{"ecosystem":"SUSE:Manager Client Tools 15","fixed":["0.28.1-150100.4.28.2"],"introduced":["0"],"last_affected":[],"package":"golang-github-prometheus-alertmanager","purl":"pkg:rpm/suse/golang-github-prometheus-alertmanager\u0026distro=SUSE%20Manager%20Client%20Tools%2015","source":"SUSE-SU-2025:4481-1"},{"ecosystem":"SUSE:Manager Proxy LTS 4.3","fixed":["0.28.1-150100.4.28.2"],"introduced":["0"],"last_affected":[],"package":"golang-github-prometheus-alertmanager","purl":"pkg:rpm/suse/golang-github-prometheus-alertmanager\u0026distro=SUSE%20Manager%20Proxy%20LTS%204.3","source":"SUSE-SU-2025:4481-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["0.28.1-150100.4.28.2"],"introduced":["0"],"last_affected":[],"package":"golang-github-prometheus-alertmanager","purl":"pkg:rpm/opensuse/golang-github-prometheus-alertmanager\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2025:4481-1"}],"prev":{"headline":"Incorrect results returned from Rows.Scan in database/sql","id":"CVE-2025-47907"},"products":["github.com/rs/cors"],"published":"2025-08-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-07","vendors":["github.com/rs/cors"]},"summary":"Attackers can cause denial of service by sending malicious preflight requests with excessive commas in headers, leading to excessive heap allocations in the Go CORS middleware.","url":"https://insights.sbomify.com/CVE-2025-47908/"}