# CVE-2025-47908: Denial of service via malicious preflight requests in github.com/rs/cors

> Attackers can cause denial of service by sending malicious preflight requests with excessive commas in headers, leading to excessive heap allocations in the Go CORS middleware.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2025
- **Updated:** 7 Aug 2025
- **Also known as:** CLEANSTART-2026-JT82999, CLEANSTART-2026-LQ54716, GHSA-mh55-gqvf-xfwm, GO-2024-2883, SUSE-SU-2025:4481-1, UBUNTU-CVE-2025-47908

## What is CVE-2025-47908?

CVE-2025-47908 is a high-severity denial of service vulnerability in github.com/rs/cors, published on 6 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Middleware causes a prohibitive amount of heap allocations when processing malicious preflight requests that include a Access-Control-Request-Headers (ACRH) header whose value contains many commas. This behavior can be abused by attackers to produce undue load on the middleware/server as an attempt to cause a denial of service.

## Which versions are affected by CVE-2025-47908?

3 open source packages ship an affected version, including github.com/rs/cors.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rs/cors` | Go | From 1.9.0 | 1.11.0 |
| `github.com/rs/cors` | Go | From 1.9.0 | 1.11.0 |
| `github.com/rs/cors` | Go | From 1.9.0 | 1.11.0 |
| `golang-github-prometheus-alertmanager` | SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 0.28.1-150100.4.28.2 |
| `golang-github-prometheus-alertmanager` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 0.28.1-150100.4.28.2 |
| `golang-github-prometheus-alertmanager` | SUSE:Manager Client Tools 15 | All versions | 0.28.1-150100.4.28.2 |
| `golang-github-prometheus-alertmanager` | SUSE:Manager Proxy LTS 4.3 | All versions | 0.28.1-150100.4.28.2 |
| `golang-github-prometheus-alertmanager` | openSUSE:Leap 15.6 | All versions | 0.28.1-150100.4.28.2 |

## How do I fix CVE-2025-47908?

Upgrade github.com/rs/cors to 1.11.0 or later.

## Is CVE-2025-47908 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47908 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47908 and fix it if it is affected.

What it is: CVE-2025-47908 is a high-severity denial of service vulnerability in github.com/rs/cors, published on 6 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-47908 exists.

Affected packages and fixed versions:
- github.com/rs/cors (Go): affected from 1.9.0; fixed in 1.11.0
- github.com/rs/cors (Go): affected from 1.9.0; fixed in 1.11.0
- github.com/rs/cors (Go): affected from 1.9.0; fixed in 1.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47908/ (Markdown: https://insights.sbomify.com/CVE-2025-47908/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47908
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47908
- OSV: https://osv.dev/vulnerability/CVE-2025-47908

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47908/
Summaries are generated and may contain mistakes; the official description above is the record.
