CVE-2025-47934 OpenPGP.js's message signature verification can be spoofed
Attackers can spoof OpenPGP.js signature verification for inline or signed-encrypted messages, allowing them to present unsigned data as legitimately signed.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-47934?
CVE-2025-47934 is a high-severity vulnerability in openpgpjs, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
OpenPGP.js is a JavaScript implementation of the OpenPGP protocol. Startinf in version 5.0.1 and prior to versions 5.11.3 and 6.1.1, a maliciously modified message can be passed to either `openpgp.verify` or `openpgp.decrypt`, causing these functions to return a valid signature verification result while returning data that was not actually signed. This flaw allows signature verifications of inline (non-detached) signed messages (using `openpgp.verify`) and signed-and-encrypted messages (using `openpgp.decrypt` with `verificationKeys`) to be spoofed, since both functions return extracted data that may not match the data that was originally signed. Detached signature verifications are not affected, as no signed data is returned in that case. In order to spoof a message, the attacker needs a single valid message signature (inline or detached) as well as the plaintext data that was legitimately signed, and can then construct an inline-signed message or signed-and-encrypted message with any data of the attacker's choice, which will appear as legitimately signed by affected versions of OpenPGP.js. In other words, any inline-signed message can be modified to return any other data (while still indicating that the signature was valid), and the same is true for signed+encrypted messages if the attacker can obtain a valid signature and encrypt a new message (of the attacker's choice) together with that signature. The issue has been patched in versions 5.11.3 and 6.1.1. Some workarounds are available. When verifying inline-signed messages, extract the message and signature(s) from the message returned by `openpgp.readMessage`, and verify the(/each) signature as a detached signature by passing the signature and a new message containing only the data (created using `openpgp.createMessage`) to `openpgp.verify`. When decrypting and verifying signed+encrypted messages, decrypt and verify the message in two steps, by first calling `openpgp.decrypt` without `verificationKeys`, and then passing the returned signature(s) and a new message containing the decrypted data (created using `openpgp.createMessage`) to `openpgp.verify`.
Weakness: CWE-347
Which versions are affected by CVE-2025-47934?
4 open source packages ship an affected version, including openpgp.
| Package | Affected | Fixed in |
|---|---|---|
openpgp npm | From 5.0.1 | 5.11.3 |
openpgp npm | From 5.0.1 | 5.11.3 |
openpgp npm | From 6.0.0-alpha.0 | 6.1.1 |
openpgp npm | From 6.0.0-alpha.0 | 6.1.1 |
How do I fix CVE-2025-47934?
Upgrade openpgp to a fixed version for your release line: 5.11.3 or 6.1.1.
Is CVE-2025-47934 being exploited?
There is no known exploitation of CVE-2025-47934 in the wild and no public exploit code.
Sources
Also known as GHSA-8qff-qr5q-5pr8, MINI-3f77-xw74-jvqm, ROOT-APP-NPM-CVE-2025-47934.