{"answers":{"affected":"4 open source packages ship an affected version, including openpgp.","exploited":"There is no known exploitation of CVE-2025-47934 in the wild and no public exploit code.","fix":"Upgrade openpgp to a fixed version for your release line: 5.11.3 or 6.1.1.","what":"CVE-2025-47934 is a high-severity vulnerability in openpgpjs, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-47934 and fix it if it is affected.\n\nWhat it is: CVE-2025-47934 is a high-severity vulnerability in openpgpjs, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-47934 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openpgp (npm): affected from 5.0.1; fixed in 5.11.3\n- openpgp (npm): affected from 5.0.1; fixed in 5.11.3\n- openpgp (npm): affected from 6.0.0-alpha.0; fixed in 6.1.1\n- openpgp (npm): affected from 6.0.0-alpha.0; fixed in 6.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-47934/ (Markdown: https://insights.sbomify.com/CVE-2025-47934/index.md)","id":"CVE-2025-47934","markdown":"https://insights.sbomify.com/CVE-2025-47934/index.md","name":"CVE-2025-47934","record":{"aliases":["GHSA-8qff-qr5q-5pr8","MINI-3f77-xw74-jvqm","ROOT-APP-NPM-CVE-2025-47934"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript OpenPGP library","requires_auth":"none","summary":"Attackers can spoof OpenPGP.js signature verification for inline or signed-encrypted messages, allowing them to present unsigned data as legitimately signed.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"OpenPGP.js is a JavaScript implementation of the OpenPGP protocol. Startinf in version 5.0.1 and prior to versions 5.11.3 and 6.1.1, a maliciously modified message can be passed to either `openpgp.verify` or `openpgp.decrypt`, causing these functions to return a valid signature verification result while returning data that was not actually signed. This flaw allows signature verifications of inline (non-detached) signed messages (using `openpgp.verify`) and signed-and-encrypted messages (using `openpgp.decrypt` with `verificationKeys`) to be spoofed, since both functions return extracted data that may not match the data that was originally signed. Detached signature verifications are not affected, as no signed data is returned in that case. In order to spoof a message, the attacker needs a single valid message signature (inline or detached) as well as the plaintext data that was legitimately signed, and can then construct an inline-signed message or signed-and-encrypted message with any data of the attacker's choice, which will appear as legitimately signed by affected versions of OpenPGP.js. In other words, any inline-signed message can be modified to return any other data (while still indicating that the signature was valid), and the same is true for signed+encrypted messages if the attacker can obtain a valid signature and encrypt a new message (of the attacker's choice) together with that signature. The issue has been patched in versions 5.11.3 and 6.1.1. Some workarounds are available. When verifying inline-signed messages, extract the message and signature(s) from the message returned by `openpgp.readMessage`, and verify the(/each) signature as a detached signature by passing the signature and a new message containing only the data (created using `openpgp.createMessage`) to `openpgp.verify`.  When decrypting and verifying signed+encrypted messages, decrypt and verify the message in two steps, by first calling `openpgp.decrypt` without `verificationKeys`, and then passing the returned signature(s) and a new message containing the decrypted data (created using `openpgp.createMessage`) to `openpgp.verify`.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenPGP.js's message signature verification can be spoofed","id":"CVE-2025-47934","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":4,"n_references":5,"next":{"headline":"Multer vulnerable to Denial of Service via memory leaks from unclosed streams","id":"CVE-2025-47935"},"packages":[{"ecosystem":"npm","fixed":["5.11.3"],"introduced":["5.0.1"],"last_affected":[],"package":"openpgp","purl":null,"source":"GHSA-8qff-qr5q-5pr8"},{"ecosystem":"npm","fixed":["5.11.3"],"introduced":["5.0.1"],"last_affected":[],"package":"openpgp","purl":"pkg:npm/openpgp","source":"GHSA-8qff-qr5q-5pr8"},{"ecosystem":"npm","fixed":["6.1.1"],"introduced":["6.0.0-alpha.0"],"last_affected":[],"package":"openpgp","purl":null,"source":"GHSA-8qff-qr5q-5pr8"},{"ecosystem":"npm","fixed":["6.1.1"],"introduced":["6.0.0-alpha.0"],"last_affected":[],"package":"openpgp","purl":"pkg:npm/openpgp","source":"GHSA-8qff-qr5q-5pr8"}],"prev":{"headline":"Argo CD allows cross-site scripting on repositories page","id":"CVE-2025-47933"},"products":["openpgpjs"],"published":"2025-05-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-20","vendors":["openpgpjs"]},"summary":"Attackers can spoof OpenPGP.js signature verification for inline or signed-encrypted messages, allowing them to present unsigned data as legitimately signed.","url":"https://insights.sbomify.com/CVE-2025-47934/"}