# CVE-2025-47934: OpenPGP.js's message signature verification can be spoofed

> Attackers can spoof OpenPGP.js signature verification for inline or signed-encrypted messages, allowing them to present unsigned data as legitimately signed.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2025
- **Updated:** 20 May 2025
- **Also known as:** GHSA-8qff-qr5q-5pr8, MINI-3f77-xw74-jvqm, ROOT-APP-NPM-CVE-2025-47934

## What is CVE-2025-47934?

CVE-2025-47934 is a high-severity vulnerability in openpgpjs, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenPGP.js is a JavaScript implementation of the OpenPGP protocol. Startinf in version 5.0.1 and prior to versions 5.11.3 and 6.1.1, a maliciously modified message can be passed to either `openpgp.verify` or `openpgp.decrypt`, causing these functions to return a valid signature verification result while returning data that was not actually signed. This flaw allows signature verifications of inline (non-detached) signed messages (using `openpgp.verify`) and signed-and-encrypted messages (using `openpgp.decrypt` with `verificationKeys`) to be spoofed, since both functions return extracted data that may not match the data that was originally signed. Detached signature verifications are not affected, as no signed data is returned in that case. In order to spoof a message, the attacker needs a single valid message signature (inline or detached) as well as the plaintext data that was legitimately signed, and can then construct an inline-signed message or signed-and-encrypted message with any data of the attacker's choice, which will appear as legitimately signed by affected versions of OpenPGP.js. In other words, any inline-signed message can be modified to return any other data (while still indicating that the signature was valid), and the same is true for signed+encrypted messages if the attacker can obtain a valid signature and encrypt a new message (of the attacker's choice) together with that signature. The issue has been patched in versions 5.11.3 and 6.1.1. Some workarounds are available. When verifying inline-signed messages, extract the message and signature(s) from the message returned by `openpgp.readMessage`, and verify the(/each) signature as a detached signature by passing the signature and a new message containing only the data (created using `openpgp.createMessage`) to `openpgp.verify`.  When decrypting and verifying signed+encrypted messages, decrypt and verify the message in two steps, by first calling `openpgp.decrypt` without `verificationKeys`, and then passing the returned signature(s) and a new message containing the decrypted data (created using `openpgp.createMessage`) to `openpgp.verify`.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2025-47934?

4 open source packages ship an affected version, including openpgp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openpgp` | npm | From 5.0.1 | 5.11.3 |
| `openpgp` | npm | From 5.0.1 | 5.11.3 |
| `openpgp` | npm | From 6.0.0-alpha.0 | 6.1.1 |
| `openpgp` | npm | From 6.0.0-alpha.0 | 6.1.1 |

## How do I fix CVE-2025-47934?

Upgrade openpgp to a fixed version for your release line: 5.11.3 or 6.1.1.

## Is CVE-2025-47934 being exploited?

There is no known exploitation of CVE-2025-47934 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47934 and fix it if it is affected.

What it is: CVE-2025-47934 is a high-severity vulnerability in openpgpjs, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47934 in the wild and no public exploit code.

Affected packages and fixed versions:
- openpgp (npm): affected from 5.0.1; fixed in 5.11.3
- openpgp (npm): affected from 5.0.1; fixed in 5.11.3
- openpgp (npm): affected from 6.0.0-alpha.0; fixed in 6.1.1
- openpgp (npm): affected from 6.0.0-alpha.0; fixed in 6.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47934/ (Markdown: https://insights.sbomify.com/CVE-2025-47934/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47934
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47934
- OSV: https://osv.dev/vulnerability/CVE-2025-47934

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47934/
Summaries are generated and may contain mistakes; the official description above is the record.
