{"answers":{"affected":"2 open source packages ship an affected version, including multer.","exploited":"There is no known exploitation of CVE-2025-47935 in the wild and no public exploit code.","fix":"Upgrade multer to 2.0.0 or later.","what":"CVE-2025-47935 is a high-severity denial of service vulnerability in expressjs multer, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-47935 and fix it if it is affected.\n\nWhat it is: CVE-2025-47935 is a high-severity denial of service vulnerability in expressjs multer, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-47935 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- multer (npm): affected all versions; fixed in 2.0.0\n- multer (npm): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-47935/ (Markdown: https://insights.sbomify.com/CVE-2025-47935/index.md)","id":"CVE-2025-47935","markdown":"https://insights.sbomify.com/CVE-2025-47935/index.md","name":"CVE-2025-47935","record":{"aliases":["GHSA-44fp-w29j-9vj5","ROOT-APP-NPM-CVE-2025-47935"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js file upload library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using Multer by triggering stream errors that leak memory and file descriptors, requiring a server restart.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-401","name":"Missing Release of Memory after Effective Lifetime"}],"description":"Multer is a node.js middleware for handling `multipart/form-data`. Versions prior to 2.0.0 are vulnerable to a resource exhaustion and memory leak issue due to improper stream handling. When the HTTP request stream emits an error, the internal `busboy` stream is not closed, violating Node.js stream safety guidance. This leads to unclosed streams accumulating over time, consuming memory and file descriptors. Under sustained or repeated failure conditions, this can result in denial of service, requiring manual server restarts to recover. All users of Multer handling file uploads are potentially impacted. Users should upgrade to 2.0.0 to receive a patch. No known workarounds are available.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Multer vulnerable to Denial of Service via memory leaks from unclosed streams","id":"CVE-2025-47935","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"TYPO3 Vulnerable to Server Side Request Forgery via Webhooks","id":"CVE-2025-47936"},"packages":[{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"multer","purl":null,"source":"GHSA-44fp-w29j-9vj5"},{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"multer","purl":"pkg:npm/multer","source":"GHSA-44fp-w29j-9vj5"}],"prev":{"headline":"OpenPGP.js's message signature verification can be spoofed","id":"CVE-2025-47934"},"products":["multer"],"published":"2025-05-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-27","vendors":["expressjs"]},"summary":"Attackers can cause denial of service in applications using Multer by triggering stream errors that leak memory and file descriptors, requiring a server restart.","url":"https://insights.sbomify.com/CVE-2025-47935/"}