# CVE-2025-47935: Multer vulnerable to Denial of Service via memory leaks from unclosed streams

> Attackers can cause denial of service in applications using Multer by triggering stream errors that leak memory and file descriptors, requiring a server restart.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2025
- **Updated:** 27 May 2025
- **Also known as:** GHSA-44fp-w29j-9vj5, ROOT-APP-NPM-CVE-2025-47935

## What is CVE-2025-47935?

CVE-2025-47935 is a high-severity denial of service vulnerability in expressjs multer, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multer is a node.js middleware for handling `multipart/form-data`. Versions prior to 2.0.0 are vulnerable to a resource exhaustion and memory leak issue due to improper stream handling. When the HTTP request stream emits an error, the internal `busboy` stream is not closed, violating Node.js stream safety guidance. This leads to unclosed streams accumulating over time, consuming memory and file descriptors. Under sustained or repeated failure conditions, this can result in denial of service, requiring manual server restarts to recover. All users of Multer handling file uploads are potentially impacted. Users should upgrade to 2.0.0 to receive a patch. No known workarounds are available.

Weakness: CWE-401 (Missing Release of Memory after Effective Lifetime)

## Which versions are affected by CVE-2025-47935?

2 open source packages ship an affected version, including multer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `multer` | npm | All versions | 2.0.0 |
| `multer` | npm | All versions | 2.0.0 |

## How do I fix CVE-2025-47935?

Upgrade multer to 2.0.0 or later.

## Is CVE-2025-47935 being exploited?

There is no known exploitation of CVE-2025-47935 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47935 and fix it if it is affected.

What it is: CVE-2025-47935 is a high-severity denial of service vulnerability in expressjs multer, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47935 in the wild and no public exploit code.

Affected packages and fixed versions:
- multer (npm): affected all versions; fixed in 2.0.0
- multer (npm): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47935/ (Markdown: https://insights.sbomify.com/CVE-2025-47935/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47935
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47935
- OSV: https://osv.dev/vulnerability/CVE-2025-47935

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47935/
Summaries are generated and may contain mistakes; the official description above is the record.
