CVE-2025-47937 TYPO3 Vulnerable to Information Disclosure via DBAL Restriction Handling
Unauthorized frontend users can access data from additional tables in multi-table database queries due to incomplete permission checks in the DBAL.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-47937?
CVE-2025-47937 is a low-severity missing authorization vulnerability in Typo3 Typo3, published on 20 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
TYPO3 is an open source, PHP based web content management system. Starting in version 9.0.0 and prior to versions 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, when performing a database query involving multiple tables through the database abstraction layer (DBAL), frontend user permissions are only applied via `FrontendGroupRestriction` to the first table. As a result, data from additional tables included in the same query may be unintentionally exposed to unauthorized users. Users should update to TYPO3 version 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.
Weakness: CWE-863
Which versions are affected by CVE-2025-47937?
10 open source packages ship an affected version, including typo3/cms-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms-core Packagist | From 10.0.0 | 10.4.50 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.50 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.44 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.44 |
typo3/cms-core Packagist | From 12.0.0 | 12.4.31 |
typo3/cms-core Packagist | From 12.0.0 | 12.4.31 |
4 more packages
typo3/cms-core Packagist | From 13.0.0 | 13.4.12 |
typo3/cms-core Packagist | From 13.0.0 | 13.4.12 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.51 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.51 |
Products include Typo3 Typo3.
How do I fix CVE-2025-47937?
Upgrade typo3/cms-core to a fixed version for your release line: 10.4.50, 11.5.44, 12.4.31 or 13.4.12.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-47937 being exploited?
There is no known exploitation of CVE-2025-47937 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as GHSA-x8pv-fgxp-8v3x.