# CVE-2025-47938: TYPO3 Vulnerable to Unverified Password Change for Backend Users

> Attackers with hijacked admin sessions can change backend user passwords without verification, leading to account takeover.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2025
- **Updated:** 20 May 2025
- **Also known as:** GHSA-3jrg-97f3-rqh9

## What is CVE-2025-47938?

CVE-2025-47938 is a low-severity authentication bypass vulnerability in Typo3 Typo3, published on 20 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

TYPO3 is an open source, PHP based web content management system. Starting in version 9.0.0 and prior to versions 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, the backend user management interface allows password changes without requiring the current password. When an administrator updates their own account or modifies other user accounts via the admin interface, the current password is not requested for verification. This behavior may lower the protection against unauthorized access in scenarios where an admin session is hijacked or left unattended, as it enables password changes without additional authentication. Users should update to TYPO3 version 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.

Weakness: CWE-620 (Unverified Password Change)

## Which versions are affected by CVE-2025-47938?

20 open source packages ship an affected version, including typo3/cms-core and typo3/cms-setup. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.50 |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.50 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.44 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.44 |
| `typo3/cms-core` | Packagist | From 12.0.0 | 12.4.31 |
| `typo3/cms-core` | Packagist | From 12.0.0 | 12.4.31 |
| `typo3/cms-core` | Packagist | From 13.0.0 | 13.4.12 |
| `typo3/cms-core` | Packagist | From 13.0.0 | 13.4.12 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.51 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.51 |
| `typo3/cms-setup` | Packagist | From 10.0.0 | 10.4.50 |
| `typo3/cms-setup` | Packagist | From 10.0.0 | 10.4.50 |
| `typo3/cms-setup` | Packagist | From 11.0.0 | 11.5.44 |
| `typo3/cms-setup` | Packagist | From 11.0.0 | 11.5.44 |
| `typo3/cms-setup` | Packagist | From 12.0.0 | 12.4.31 |
| `typo3/cms-setup` | Packagist | From 12.0.0 | 12.4.31 |
| `typo3/cms-setup` | Packagist | From 13.0.0 | 13.4.12 |
| `typo3/cms-setup` | Packagist | From 13.0.0 | 13.4.12 |
| `typo3/cms-setup` | Packagist | From 9.0.0 | 9.5.51 |
| `typo3/cms-setup` | Packagist | From 9.0.0 | 9.5.51 |

Products: Typo3 Typo3.

## How do I fix CVE-2025-47938?

Upgrade typo3/cms-core to a fixed version for your release line: 10.4.50, 11.5.44, 12.4.31 or 13.4.12.

## Is CVE-2025-47938 being exploited?

There is no known exploitation of CVE-2025-47938 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-47938 and fix it if it is affected.

What it is: CVE-2025-47938 is a low-severity authentication bypass vulnerability in Typo3 Typo3, published on 20 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-47938 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.50
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.50
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.44
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.44
- typo3/cms-core (Packagist): affected from 12.0.0; fixed in 12.4.31
- typo3/cms-core (Packagist): affected from 12.0.0; fixed in 12.4.31
- typo3/cms-core (Packagist): affected from 13.0.0; fixed in 13.4.12
- typo3/cms-core (Packagist): affected from 13.0.0; fixed in 13.4.12
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.51
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.51
- typo3/cms-setup (Packagist): affected from 10.0.0; fixed in 10.4.50
- typo3/cms-setup (Packagist): affected from 10.0.0; fixed in 10.4.50

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-47938/ (Markdown: https://insights.sbomify.com/CVE-2025-47938/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-47938
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-47938
- OSV: https://osv.dev/vulnerability/CVE-2025-47938

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-47938/
Summaries are generated and may contain mistakes; the official description above is the record.
